cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - New to the community? Learn how to post a question and get help from PTC and industry experts! X

Urgent. Remove enable_embedded_component_demo

ErikClacey
12-Amethyst

Urgent. Remove enable_embedded_component_demo

Hi,

 

I tried the hidded function enable_embedded_component_demo in Creo 6 as a means of reducing the number of files/parts created when importing for xample step files. The problem now is that it seems to have "contaminated" the files and I cannot open any files when I turn this function off.

 

The error I get is "This model ad been created with a Creo 5.0 demo version for embedded components and cannot be retreived"

 

Furthermore, som components have been worked on and checked into Windchill. So reverting to a previous version is not an option.

 

Please help!

1 ACCEPTED SOLUTION

Accepted Solutions

You are not the first to have this issue as there is a support article addressing this.

 

  • Workaround:
    • Open an lower iteration of the assembly which was saved before applying the config option enable_embedded_component_demo to yes
    • To open a lower iteration of file, refer article CS289032 

 

 

Refer to this article for details:

https://www.ptc.com/pt/support/article/cs306233#:~:text=If%20hidden%20config%20option%20enable_embedded_component_demo%20is%20set%20to,Aplica-se%20a%20Creo%20Parametric%205.0.0.0%20to%205.0.1.0%20Descri%C3%A7%C3%A3o 

 

 

PTC does not support hidden config options and explicitly warns against using them in a production environment. 

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric

View solution in original post

7 REPLIES 7
StephenW
23-Emerald II
(To:ErikClacey)

It is highly unlikely other users will be able to help you.

You will need to contact PTC directly (or your VAR). Not sure how much they can help but it's likely your only option.

Ok, thanks. Yes, I contacted the support team from our reseller. The only option seems to be to revert back to an earlier version of the files, or delete the new ones made during this period.

You are not the first to have this issue as there is a support article addressing this.

 

  • Workaround:
    • Open an lower iteration of the assembly which was saved before applying the config option enable_embedded_component_demo to yes
    • To open a lower iteration of file, refer article CS289032 

 

 

Refer to this article for details:

https://www.ptc.com/pt/support/article/cs306233#:~:text=If%20hidden%20config%20option%20enable_embedded_component_demo%20is%20set%20to,Aplica-se%20a%20Creo%20Parametric%205.0.0.0%20to%205.0.1.0%20Descri%C3%A7%C3%A3o 

 

 

PTC does not support hidden config options and explicitly warns against using them in a production environment. 

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric


@ErikClacey wrote:

Hi,

 

I tried the hidded function enable_embedded_component_demo in Creo 6 as a means of reducing the number of files/parts created when importing for xample step files. The problem now is that it seems to have "contaminated" the files and I cannot open any files when I turn this function off.

 

The error I get is "This model ad been created with a Creo 5.0 demo version for embedded components and cannot be retreived"

 

Furthermore, som components have been worked on and checked into Windchill. So reverting to a previous version is not an option.

 

Please help!


Might be good excuse to upgrade to Creo Parametric 8.0 which supports inseparable assemblies:

https://www.ptc.com/en/support/article/cs349444

It would be fairly easy to install a seat of Creo Parametric 8.0 and see if it will open these "contaminated" assemblies.

Thanks. Yes, I tried it now in Creo 9 but it wouldn't open. So I've now replaced everything with earlier iterations.

 


@ErikClacey wrote:

Thanks. Yes, I tried it now in Creo 9 but it wouldn't open. So I've now replaced everything with earlier iterations.

 


Seems rather lame that PTC does not support these enable_embedded_component_demo assemblies, in Creo Parametric 8.0 or newer, now that inseparable assemblies are now officially supported. I wonder if that is an oversight or whether some major under the hood changes actually took place between the "demo mode" and the "Creo Parametric 8.0+ real mode".

The UI appears to be very similar if not the same.

 

Somebody from PTC care to make a comment on this?

Thanks tbraxton for the reply that perfectly summarizes related links and policy..

But to give you all a re-confirmation:  Yes, there had been significant changes under the hood between demo and production and 
that's why the data created with early alpha/beta/demo versions had been  marked as incompatible (to production/released data). and why the warnings had been added as outlined in the above article. 

Top Tags