cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

assembly components missing in drawing

vincecatlin
Regular Member

assembly components missing in drawing

I have an assembly drawing with some parts missing. I have tried all the obvious fixes. This is the master rep. I do not get the option of unblank - message bar says there are no blanked assembly members to unblank. I have "turned it on and turned it off again" or would not be here seeking a solution.

I have never seen this before.

Tags (2)
9 REPLIES 9

Re: assembly components missing in drawing

I guess I should probably add that the asembly is behaving perfectly. It's the drawing that is not.

Re: assembly components missing in drawing

Just shooting in the dark, but did you:

1) Start a brand new drawing with this assembly as the only model?

2) unblank all drawing layers?

3) make sure that the view you are using isn't in a some "default" explode state where some of the components are inside other components?

4) Run the detail option "update_drawing", with the value "all" ?

5) Run the Review Tab -> Update Sheets command?

 

Re: assembly components missing in drawing

Also, did you try switching the view to wireframe? I've had similar missing components only to find out it was because some of them were assembled with a little bit of an intersection between two of them. The hidden line algorithm then decided they were not there.

Re: assembly components missing in drawing

Just so everyone's aware, this is all in our Windchill data base so there's that one extra level of fun.

The simple fix that I settled on yesterday was to create a new drawing. Of course I first had to deal with the Windchill functionality and rename the drawing with the missing components. I gave it some snarky name since it was behaving badly. As one might expect, since the assembly looks fine, the drawing also looks fine.

I did not try "update drawing with value all" but that would be an interesting experiment.

I seriously thought I tried pretty much everything (layers and states and views, and etc...) and you can bet my first choice would NOT be to start a new 3 sheet drawing. Thanks for the response. Lets call this one solved.

Re: assembly components missing in drawing

I'm curious - why did you bother renaming that drawing that was giving you issues with a snarky name?

If it doesn't matter, then you should just delete it.  If it is important to keep this object b/c of its revision history, then this is the procedure I'd use:

 

Suppose your old drawing in Windchill that gave you the component display headaches was called "problem.drw":

 

1) Start new drawing, call it "temp.drw"

2) Make it look all good.

3) Save a backup of it to your local drive.

4) Close everything and erase all from memory.

5) On your local drive, delete everything, except the drawing "temp.drw"

6) Rename it to the proper name "problem.drw"

7) Import "problem.drw" to your workspace (mark it "as modified" so to overwrite the existing workspace version)

(all dependents identified will be "ghost objects", but those can just be can be marked as "reuse existing")

 

oh wait, this seems just as complicated 🙂

 

Re: assembly components missing in drawing

Yeah, it's a bit complicated either way.

We sometimes substitue a new or different local file (which also exists in the data base) by navigating to the commonspace version and checking out. For extra convenience the newer versions of Windchill will default to "re-use" But in this case it was handy to have the old drawing as a temporary reference.

Re: assembly components missing in drawing

Try checking if the missing part has some bad surface that make creo read it as a quilt, I found a small surface that prevented creo to see the part as a solid.

Re: assembly components missing in drawing

For reference, what version and build code are you using? (There seems to be a dividing line between Creo 3.0 and 4.0 for methods of managing visibility.)

Dave Martin - dmartin@creowindchill.com - https://www.creowindchill.com

Re: assembly components missing in drawing

We're now on Creo 4.0  M040 and I haven't seen this problem since the last time (August of last year) So we must be doing something right.

Announcements