Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

mat'l removal simulation: "Could not tessellate"


mat'l removal simulation: "Could not tessellate"

Posting this question for a co-worker, will do my best to use the correct terminology.

Creo 3.0

In Mfg he brings in the “stock model” (raw casting)

Next he brings in the “reference model” (finished part)

Both models appear normal on the screen.

Hits a menu option “Play Path” seems to work , and displays on the screen correctly.

The problem:

He wants to use the menu option “Material Removal Simulation” in Module Works. When he makes this menu selection, the casting and finished part disappear and we find two messages in the Creo message log window:

“Could not tessellate stock model”

“Could not tessellate reference model”

Any ideas?

He has used the "Material Removal Simulation" before and it has worked correctly.

He has also had the error before, so it's not unique to this current part.

Thanks for your feedback.   Bruce


Re: mat'l removal simulation: "Could not tessellate"

Not sure if this is the answer or not but the Raw casting model might need to be classified as stock if it is just a part model? I usually build a stock model and everything works.


Re: mat'l removal simulation: "Could not tessellate"

A little progress to report but our problem is still not fixed.   My co-worker tried playing with the Classify pick and it's sub menus.  He thinks he understands the intent of the "classify" button now, but it did not provide a fix.

We discovered the raw casting model (a creo.prt file) had several geom checks.  They were all related to rounds that didn't have any bearing on the machining we are trying to do so I deleted them until I had a geom check free model.

The cleaned up raw casting model was brought in and we got further.  One error message is gone but we still have the problem of the raw casting (work piece) not displaying and we still have this error: "could not tessellate stock model"

To me it's counter intuitive.  The raw casting we fixed still has the problem but the reference part errors went away.

Is that a clue to someone smarter than me?

Re: mat'l removal simulation: "Could not tessellate"

Is there any chance there is an accuracy mismatch?

Re: mat'l removal simulation: "Could not tessellate"

An update so I don't leave this subject hanging...

Following up on the good suggestion we investigated an accuracy mismatch. Both models were the same. Later I did some playing with importing a step file of our casting into a new part with more and more accuracy but that didn't get me anywhere.

When I went through the process of exporting a step file (of our casting) then re-importing it into a new part, I was able to see some questionable areas that didn't show as geom checks in the original casting model. If you want to try this: when importing a step file, hit the Red Cross Import Data Doctor button and there is a geom check embedded in there. When it was something I could easily fix like a round we didn't need for mfg I would go back and delete it and try again. After a couple of iterations I finally had a very clean model to work with. With high hopes we brought this into his mfg program but we still got the “ Could not tessellate stock model” error.

We are out of time on this particular project so he's going to move on. He said he can manually step through the program and look for crashes. To those of you who use this mfg software: I may not be describing this last part correctly.

Problem not solved. If it shows up again on a simpler part we may chase it further.

Thanks for your time, Bruce

Re: mat'l removal simulation: "Could not tessellate"

Hello, I think you should open a case to support to find what is the problem. Maybe it's a bug they should resolve.

Re: mat'l removal simulation: "Could not tessellate"

Not sure, but usually I import first the reference then after the stock model. It looks like your colleague is doing in the other way.

Re: mat'l removal simulation: "Could not tessellate"

I'm not sure what he usually does but when I was watching him the reference model was in place then he added the stock model.

Re: mat'l removal simulation: "Could not tessellate"

When I have seen that error is was due to not using absolute accuracy and or having complex geometry.  There are also some settings to consider inside of module works itself i have attached the settings file I use

Re: mat'l removal simulation: "Could not tessellate"

Found the problem !

I kept wondering that if the casting model was the problem, could it be "healed" by translating it into another format then back into a creo?  Creating a step file didn't give us results so I next tried creating a .stl file.  I didn't research it but was hoping the .stl could then converted back to a .prt file somehow.

The first attempt at creating a .stl file failed with these error messages:

"Unable to triangulate highlighted surface. Aborting output."

"Unable to triangulate part BDP146-P4-040C_REV_03_3.  Aborting output."

I couldn't find the highlighted surface but the message led me to believe the software identified a problem that was localized.  I found the problem area by:

- creating a cut  (side view) as the last feature in the model tree and hacked away 90 percent of the casting.

- retry creating the .stl file.    (success!)

- edit the side view cut to re-introduce the casting a chunk at a time.

- repeat the process until the .stl creation fails again.

In this case I was able to narrow the problem down to a small area.  I changed the side view cut feature to a surface so I could see where I had been and next went to a front view and used the same method to narrow down the problem area even more.


It appears the problem is in a round that was built with surfaces in an area of the casting that's nasty to work on.  Since we are crunched for time, I left the cut feature that found the problem in place and used it to just remove the problem.  My co-worker was so happy when it worked he offered to restore my 1960 Chrysler!  No, not really.

Summary:  I don't know why the problem exists but it is related to a round between two complex surfaces.  Geom checks didn't flag the problem, but a .stl model could not be created because of the problem.  The .stl creation process was used along with cuts to remove material to get a work piece that would display properly in mfg.

Thanks everyone for your input!    Bruce