Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

interchang asm - lost link


interchang asm - lost link


I have a family. Some instances replace a prt by another one using an interchange.

The interchange is pretty basic: only 2 parts.

Parts and family have been released.

Now, time for revision (parts and family)

The interchange doesnt work anymore! Somehow, the links between it and the parts are gone. At loading the interchange, error messages appear like "WARNING: Component xxxxx has no reference to interchange, removing...."
The interchange appears, empty.
An update of it.. and parts are back.

But... without real link. From the part side (opened from the assembly) edit/setup/interchange/show --> not part of any interchange

From the family point of view: the interchange is not even shown in the reference viewer anymore.

ProE WF4
PDMLink: 8

This is a huge blocker in my work.

(I got some similar issues before, but it was during development, before the release process, and it didnt really affect so far)

(actually, I have another interchange in this assembly which doesnt work anymore either, but I could solve this issue by using coord sys instead)
I tried to load them in any order / regenerate ... nothing works. The only thing which looks to have an effect seem to check out everything, empty the IA, and put the prt back. But it creates 2 issues:

- one of the part is not available now for revise and can't be check out.

- stability over time and further promotion process

--> Why!?

--> How to repaire/solve !?

Thanks for your help

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
5-Regular Member

Check the same problem I had with solution at:

Interchange components disappearing.

Top Tags