Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

preselect highlighting issues- graphics card or something else?


preselect highlighting issues- graphics card or something else?

I've tried searches for this, but haven't found anything. Recently switched from WF4 to Creo2.

I have problems with the preselect highlighting disappearing from windows. If I have more than one window up, as I usually do, the preselect will work fine in one window, and will quit working in another.

I can get the preselect back if I close the window and reopen (no need to erase/not displayed), but this is annoying.

When the preselect stops working, the preselect option will be turned off. If I turn it on, and then come back to look at the option again, it will be turned off.

Addtionally, I frequently can't get pipeline segments or pipelines to highlight in my model tree when doing piping, and can't select the pipe solids without exiting Piping. Again, exiting and coming back into the window usually restores the function.

I have tried the compatibility fix I found elsewhere, and it did not fix this problem.

I have updated all my drivers.

We have a bunch of identical computers here running without problems.

The guy next to me runs the same configuration (excepting my trackball), and doesn't have problems.

My configuration:

I have a Dell T1600 running a Nvidia Quadro 2000 card. (the K2000 is certified for Creo, not the 2000, FWIW)

3dconnexion SpaceNavigator

Logitech M570 trackball.

Windows 7 64 bit

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

Accepted Solutions

When you lose preselection highlighting, try a 'Repaint'.

View solution in original post


I have had this problem in WF4, WF5 and Creo 2. I'm using the Space Mouse Pro, but have seen this problem with the original SpaceBall also. When I turn the highlighting on again, the box is check but has no effect. It makes is very difficult to make simplified reps. Closing and reopening the window doesn't help for me. I have to exit Creo and reload the file. I work with large files, so this can take 40 minuets.

I am assuming the driver turns off the highlighting while it moves and fails to restart it.

I have used a Spaceball with Pro/E since about 1998 and haven't seen this problem before WF4.

I've used a SpacePilot since ProE 2001 (WF2, WF3, WF4, and currently on Creo2) without any problems like that related to the mouse. I was thrown for a loop once when prehilighting would randomly disappear...thought I was loosing my mind. Turned out my desk was a mess and a piece of paper was touching the SpacePilot knob .

I also had a similar problem on WF4 with a 3rd party program that managed multiple desktops/taskbars. Went away once I uninstalled the program.

Are you using Dell or nVidia drivers for your video card? I've heard of people having problems with nVidia drivers on video cards from Dell though I've never experienced it myself.

Dell T3500

SpacePilot driver ver 1.12.2

Creo 2.0 M070


Quadro 5000

You're probably onto something there with the Dell/Nvidia, which is what I have. I went back to just a mouse, and didn't have the problem. Then I added my trackball, and didn't have the problem. Then I added the 3dconnexion mouse and the problem reappeared. The guy next to me has a regular mouse and the 3dconnexion, and doesn't have these problems. I have to think I'm asking a little more than my graphics card can handle, somehow.

At this point I just have to close windows and reopen them, or close Creo and restart. For the most part it's more annoying than critical, and I'm not willing to give up a setup that works well.

If you remove the trackball, does the problem go away? Also, try using Dell's driver for the video card (I'm assuming it was purchased through Dell) by downloading it, uninstalling the nVidia driver, and installing Dell's. It used to be that you had to use an nVidia driver cleaner before installing something else but I don't know if that's the case anymore.


If you say that your collegue runs the same configuration, does this statement apply also to the

It could be that you have some settings there that are causing the problem. Try running WITHOUT or by leaving out all options except the ones that have a path in it (you will probably need those to run Creo).


Steward Berns

GPO Solutions

Trying someone else's is my next step. I tried the Dell driver, and it didn't fix the problem. I havent' tried taking off the trackball, but I'm not giving that up, as after using a trackball for years, a mouse is just annoying.

I appreciate everyone's answers; I'll keep working at it.

Shouldn't be a pointer device issue at all. From what I understand, the PC doen't care, it's just a pointing device. Sounds like a software or setting issue.

Best of luck!

I haven't tried running without a config, but I did copy the and protk files from the guy next cube who has an identical system to mine, excepting the trackball.

No change to the preselect highlighting problem. I also have issues with pipelines not highlighting in the tree when selected on the screen, and occasional buttons like the camera icon (rep/orientation/section) disappearing

I think I'll have to take the advice to turn off the preselect highlighting completely.

Turn off preselection highlighting ( option: prehighlight no) and use "query-select" to select objects/references instead. Much better, and you always know exactly what was picked.


I eventually turned off preselect, as nothing I did made any difference to my problems with the preselect highlighting.

One question: When using Analysis between surfaces, how do you ctrl_select? If I select my first surface and need to control select the second, and I use query, and toggle through the selections available to get the right surface, my only option is to hit OK. And that removes the original selected surface.

I can make the query the first surface, I know. But what if I have to query both surfaces?

Hold down the CTRL button when you right click the second surface to pick from the list. After that, you don't need to hold it down.

After making your first selection, press and hold the CTRL key, query and select your second surface, release the CTRL key.

This is more FYI than a solution to the preselcetion disappearing trick that can only be reactivated by closing the active file and reopening. Frank S has the other option right, turn it off in the config.

I'm having the same problem with preselection, that is until I updated from Creo M080 to M090. Now I have no menus or buttons on my Spacepilot Pro (SPP) since the update to M090. The SPP worked great (excpet for preselection) in Creo M020, M080, WF4.0 and Solidworks2013, all of which I have on my desktop as well as my laptop. The desktop is a custom build and the laptop is an Acer, both run Nvidia cards, desk is quadro 4000, laptop is 680M, both setups use two monitors.

Two differnt workstations, and each has it's own: SPP, Logitech MX5500 keyboard/mouse, and Vistablet pen tablets.

Both workstations are set up to run (2) startups of WF4, (2) startups of Creo 2.0 and (1) startup of Solidworks 2013.

The SPP was working perfectly with all startups, of all programs, until I updated Creo to M090. I have already verified that the SPP still works the same way with all startups and all programs, except for Creo datecode M090.

I've updated rivers, rolled back drivers, uninstalled and re-installed.. it's a problem with M090.

Something was changed in the update from M080 to M090 and I have already logged a case with PTC tech support: C11810883

Hopefully we can find a solution and fast.. it feels as if my left hand has been cut off and my productivity is affected, because 90% of my work is on Creo.

If you have no buttons at all and you don't have the configuration menu (Tools tab-->Toolkit-->Tools-->3Dconnexion) then it sounds like your protk.dat file may have either been overwritten or your isn't pointing to the correct protk file or path.

Protk tells Creo where to load the SPP files from so that would make sense if you don't have any buttons/menus. Locate your protk.dat file, open it and verify that there are entries for your SPP (about 3 lines or so), then make sure your points to the file or else leave the protk file in your start directory.

If you are missing the SPP entries in the protk file, there are example protk files in the 3Dconnexion folders for your operating system and version of Creo/ProE. If your company has custom programs that they run from Protk, make sure you add the SPP entries into the file and don't overwrite the file.

That was it!

It's the protk.dat file that has been overwritten by the update M090.

What I found in the M090 protk file was this:


I added the command line as you suggested and it failed.

I deleted the original text command sequence shown above and saved this:


I also changed the path in my

It now works as it should, all menus buttons and the motion control is noticably better after the Nvidia driver update.

When I first had problems, I thought about the protk and dismissed it.. simply because I didn't have to do anything with it when I installed all of the design programs.. it just worked with the SPP/ CAD programs (and previous updates) working together to make the right connections.

Many thanks for the help Eric T, and I will forward the info to PTC support to close the case.

Best Regards!

22-Sapphire I

Interesting, I'll have to remember this if the problem crops up. Thanks!

When you lose preselection highlighting, try a 'Repaint'.

Wow. It works. I usually have to repaint while assembling components, but it works. thanks!

Thanks for that Lance. I was about ready to toss my computer out in the snow over the preselection.I too have a Spaceball 5000, and figured it was related to that.

Top Tags