cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

Arbortext ACL initiation errors

SindyYoung
2-Guest

Arbortext ACL initiation errors

I got error when starting up Arbortext.



Arbortext Editor Response:


[A18115] Error in initialization file: C:\Program Files\PTC\Arbortext Editor\adapters\com.ptc.prowt.arbortext\init\WindchillAdapterInitializer.js,


(A12281) Cannot create a Java virtual machine from


“\\....\jre7\bin\Client\jvm.dll” (-1).



James


5 REPLIES 5

Hi Sindy--



Have you modified your javavmmemory setting in one of your other init
files? Sometimes if you try to set it too high it will cause the JVM to
fail to start, which would give this error.



Maybe try starting up a "plain vanilla" Editor session, with no
customizations, and verify that it works correctly. If it does, then you
know it's something to do with your customizations, so start checking
for anything that affects JVM startup, like javavmmemory, javavmpath,
javavmargs, etc.



If even a plain vanilla Editor with no customizations won't start, then
check any java-related environment variables, e.g. APTJAVAVMARGS,
JAVA_HOME or JAVA_OPTS.



--Clay





Clay Helberg

Senior Consultant

TerraXML


No, I have not modified the javavmmemory setting.

Clay,
We changed our settings back to java 6.1 and everything seems to work fine. Perhaps Arbortext is not compatible with Java 7.1
Sindy

Sindy:

Just went through this issue ourselves. Arbortext Editor 5.4 is only certified for JRE 1.6.0_34 as of M140.

John Sillari
Chief Technologist
Dayton T. Brown, Inc.

We encountered this earlier in the year, but since it was isolated to a
single user (probably someone proactive about running Java updates), I
temporarily used the javavmpath setting to set to a local copy of an older
jvm.dll within an acl in custom/init

set javavmpath="C:\ptc\jvm.dll"

I've been meaning to get around to finding the "preferred" approach to
setting this, so I'm wondering what everyone else has done.

I'm sure there's some easier way to do this (eg: JAVA_HOME env var), but I
wasn't sure at the time off the top of my head. Hopefully this is
something I can configure into our patches, since we use the automatic
CUSTOM patch deployment within Arbortext.

keith

Top Tags