Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need help navigating or using the PTC Community? Contact the community team. X

Arbortext PE PDF composition Fails


Arbortext PE PDF composition Fails

Arbortext Publishing Engine , Publish to PDF fails with below error


APP did not produce an output file

<Message> Error return '0' from PDF generator. </Message>
<Trace> java.lang.Exception: Error return '0' from PDF generator. at com.arbortext.e3c.PdfServerExtension.doCompose( at com.arbortext.e3c.ServerComposer.doCompose( at com.arbortext.e3c.Application.doPost( at com.arbortext.e3.subprocess.EpicE3AppContext.doJava( at com.arbortext.e3.subprocess.EpicE3AppContext.handleE3AppRequest( at com.arbortext.e3.subprocess.EpicE3AppContext.doRequest( </Trace>


Attached debug log. Any help is appreciated.


The following lines show the failure:

[pid=2768] - 19:56:30.825 - compose doc 0x2D01A288 with D:\ptc\arbortext_pe_8.0\application\com.trane.sma\doctypes\servicemanual\
[pid=2768] - 19:56:31.076 - begin CA3B2Progress::DoPrint()
[pid=2768] - 19:56:31.078 - Preparing Document
[pid=2768] - 19:56:31.080 - begin lib3B2::lib3B2Document* Load3B2Document()
[pid=2768] - 19:56:31.081 - end lib3B2::lib3B2Document* Load3B2Document() - fail

It looks like PE cannot load the document for publishing. If you use PE Interactive you might be able to get more debugging information.

You are attempting to publish with a DITA Map a Trane-specific stylesheet called "". Does the same error occur if you publish the DITA Map using the out-of-the-box stylesheet? If you have the same error then it is likely something with your network or file path. If the error goes away then it is something to do with the stylesheet. Either way, you should probably report this to PTC Support so they can investigate, too.

I hope some of the above helps.

Thanks for the suggestions. PTC is already investigating the issue.

Please if you can elaborate more on the file path - Is the path of DITAMap or PE install path?



I believe this error message is referring to the 3B2/APP (.3D) document itself. The way this works, as I understand it:

  1. The .style file is interpreted and compiled by Arbortext to produce a .3d file
  2. The input data (DITA Map) is "flattened" and resolved to form an RDS (resolved document for styling) XML
  3. Arbortext instructs the APP engine to load the .3d file
  4. APP engine runs the .3d file which in turn loads the RDS XML and does the typesetting of the pages
  5. APP engine outputs the PDF file

So it may be failing at step #3. This is just a guess. Perhaps there is an error in the stylesheet.


There is a potential problem with installing PE related to the Visual C++ runtime package.  Please download and install the 2019 Visual C++ runtime package from Microsoft.  (This package includes that for 2015 - 2019.)

Top Tags