cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

How to add XSD of S1000D Issue 4.1 in Arbortext 5.4

karlik.richard
1-Newbie

How to add XSD of S1000D Issue 4.1 in Arbortext 5.4

Hi,


Now we use DTD of S1000D issue 3.0. And we would like to create DM according to issue 4.1 with xsd.


We don't have PTC Architect. We connected dm xsd, but editor is not able to choose elements andmessage "Insertion of text not allowed in this context" appears.


Can you help us?


Thanks

7 REPLIES 7

Hi Richard,



Welcome to my boat. 😉



If you have downloaded the issue 4.1 stylesheets locally, In Arbortext
Editor you can use File/New, click on the Browse button, drill down to
the folder "xml_schema_flat" in that S1000D issue, and select any of the
xsd files such as "dml.xsd". Click on the button Open. A dialog box asks
if you wish to add document type dml to the list? I'm not ready to do
that yet so I click on the "No" button. A dialog box then appears
because No Stylesheet Found, so I click on the "None" button because I'm
not ready to associate one yet. An empty data module will then open in
the editor and you can edit the file. You may not be able to bring the
data module into the CSDB at this time. This spec was just released
recently so you'd have to edit them as standalone files.



Greg


Hi Greg,

I proceed exactly how you described. I create empty data module, but I can’t edit DM, because I can’t insert any elements.


I don’t know where problem is.


Rich

Hi Richard,



Oh, I'm sorry for the confusion, perhaps "dml.xsd" wasn't the best
example. I hope the following will get you started. In Arbortext Editor
you would have to choose your *.xsd file based on the type of data
module you wanted to create. If you wanted to create a procedure for
example you would choose File/New and open "proced.xsd" following the
steps as before. When the procedure Data Module opens if you scroll down
the markup you will see the element "mainProcedure". If you place your
cursor between the tags and press "Enter" on the keyboard you will see a
context menu which allows you to choose the next element, such as
"proceduralStep" in order to begin authoring and adding content, e.g.



<mainprocedure>

<proceduralstep>

<para>something</para>

</proceduralstep>

</mainprocedure>



As you can see I added the element "para" within "proceduralStep" by
placing the cursor within "proceduralStep" and using the "Enter" key to
bring up the next set of elements. I then typed "something" within the
"para" element.



In case you are not familiar with the interface you can also use
"Insert/Markup" from the menu to bring up the Insert Markup Menu, or
press Ctrl-Shift-M. The content of this menu will change depending upon
your cursor's location. It will show you the valid choices for the
current position of your cursor. If you click in various positions in
the markup you will see the tags in the menu change. You can double
click on the items in the menu to enter them in your markup.



The S1000D Data Module will be missing a lot of content and attributes
in the "identAndStatusSection". If you were to click behind the element
"dmCode" and press Ctrl-D you would be presented with the Modify
Attributes dialog box which allows you to set the SNS code for the Data
Module. However you would have to check the spec to see what you need to
add to this part of the document.



I hope you understand that this is ad-hoc editing. I'm just beginning to
tinker with the new spec myself and I have decided not to add Issue 4.1
to my Custom Doctypes folder just yet.



All the best,



Greg


Hi Greg,


I understand, but the problem has still continued.


Before procedure Data Module opens, the following message is appeared (ref figure). I press OK and DM opens. I want to insert element for example <proceduralstep> into <mainprocedure>, but I can’t and the text in the bottom line shows "Insertion of text not allowed in this context".


It is very interesting that Arbortext v5.3 works OK and Arbortext v5.4 doesn’t.


I am not Arbortext expert, cannot this problem be in the elements mapping?


Can you any idea?


Rich

A message like that when trying to insert an element, in my experience,
usually occurs when you try to use the method of pressing "Enter" to get a
pop-up list of allowable elements to insert. There are a few ways this
method can fail, which usually causes Editor to fall back to inserting a
carriage return into the document, which can cause that error if only
elements are allowed at that location.

Have you tried some of the other methods that Greg mentioned, such as the
"Insert Markup" dialog or toolbar item?

-Brandon 🙂


Hi,


I must apologize to Greg.


I tried it again and second method (from menu) works OK.


Thank you very much.


Rich

Hi Richard,



No worries! I'm running 5.3 of Arbortext Editor which is probably why I
didn't see the behavior you were encountering in 5.4 of the Editor. I'm
glad the Insert Markup Menu works! Thanks Brandon for the tip regarding
the behavior of the enter key.



Greg

J




Top Tags