cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

Import/Export Schema includes read error

ChrisWestern
7-Bedrock

Import/Export Schema includes read error

Hi Everyone


I'm having a problem with import/export that i'm hoping someone else may have encountered before!


When creating a new map template, the schema (valid and working in Editor and XML Spy etc) I am loading in is coming up with an error and resluts in missing some of the element definitions. (Arbx 6.0 M010)


Error dialogue:


Schema has been loaded, however there had been some unresolved Entities, Error log file bla bla ...

Error log sample lines:



  • Group Not found :h:inline

  • Referenced Element not found :h:div

  • Referenced Element not found :h:p



It is a custom schema with a number of modules, imports, includes and dependancies. The missing parts come from references in one module pointing to elements, simple types and groups called from an 'included' xhtml-transitional.xsd (standard) module.


As everything is fine using this schema for parsing and every other XML tool i have tried, i am thinking that the DTD/Schema reader in the import/export map editor does not like either imports/includes or complex 'referenced' namespaced dependacies like this.


Has anyone else come accross any similar errors and suggest any options or work arounds?


Many thanks
Chris

PS: Support call outstanding with PTC, waiting ...


PPS: found nothing relevant in the help center




Chris Western
www.tformat.com



3 REPLIES 3

Hi Chris-



I don't have an answer for you about why it is having trouble reading
your schema, but I just wanted to point out that loading the target
schema is optional. If you know the structure of the output document
pretty well, you can build the map template without loading the schema.
Just type the element names instead of selecting things in the schema
tree view for output steps. I frequently do this when building map
templates, since I don't find the schema browser to be that helpful
anyway.



If you really want to load the schema while building the map template,
you might be able to use a tool like Trang to make a flattened version
of the schema that you could use with the Import map editor.



--Clay



Clay Helberg

Senior Consultant

TerraXML



Hi Clay, thanks for the reply.


I tried a few other tools to flatten it but they did not work so might have a go with Trang also, thanks for the tip.


I'd hoped to avoid manual/non schema helper steps but looks like this might have to be the way to go.


Best Regards
Chris





Chris Western
www.tformat.com


At least i know i was not going mad.


FYI; This issue was finally accepted as a high severity SPR!




Top Tags