Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

No Graphics in Composed PDF


No Graphics in Composed PDF

We recently upgraded from Epic 5.4 to Epic 6.0.. The graphics show up in the XML file, but do not show in the composed PDF. Is there a setting I am overlooking? I went back and looked at all of the settings in 5.4 just to check, but everything in 6.0 seemed to be pointing to the right directories. Any help would be greatly appreciated!


Are you publishing through PE (aka E3 aka Publishing Engine)? If so, have you upgraded your PE server to 6.0 as well? Does the PE server still have access to the network drive storing the graphics? There is a setting to force Editor to send all images "over the wire" to PE for composition which might be worth checking.

We are going through the PE server, and have upgraded to the 6.0 server. I am not sure if the server has access to all of the graphics, as I am not the admin. I do know that the graphics are showing in the XML file.. I would be interested in knowing the setting that forces the graphics "over the wire". Thanks again for your help.

I found a support knowledge base article that is relevant:

The setting I was referring to is an "advanced setting" called pegraphicpi. If you set pegraphicpi=on then it won't send graphics. If you set pegraphicpi=off then it will send graphics.

I haven't tested but toggling that setting may be a quick way to determine where your problem lies.

I do not have the option pegraphicpi in the advanced settings:


I also can't get to the article due to account permissions.

To access the knowledge base your organisation needs to have an active PTC maintenance agreement and your PTC account needs to be associated with your organisation.

The pegraphicpi since 6.0 has been defaulted to "off" and hidden from the UI. You can still set/check the value using the Arbortext command prompt. Once you enable the command prompt you can type commands such as:


set pegraphicpi=on

set pegraphicpi=off

These commands, in order, check the current value, set it on, set it off.

This may not solve your problem but might help narrow it down.

Using the command prompt, I checked the value, and it was initially "off". I toggled it off and on using the strings you provided. In both settings (off and on), there are still no graphics in the published PDF.

Thanks again for your help with this issue.

OK great, that rules out the "pegraphicpi" as the source of the issue. Your next step is to try and compose using "PE Interactive". The "PE Interactive" application looks and acts much like Editor but must be run on the PE server itself. The shortcut to PE Interactive is in the Start Menu on the PE Server.

Once you load PE Interactive, load the XML file you are testing with and see if the compose to PDFworks as you expect.

When I try to go directly to the PE, I get the following:


You might need to talk to your server admins. To access PE Interactive you actually need to be using the Windows Desktop of the server machine itself. Normally that is only accessible to administrators, typically via what is called Remote Desktop or RDP.

The screen you are showing is the PE Servlet which is a web application interface. This interface probably won't help you debug the issue at this stage.