cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

QuickTags not displayed

rmcgarvey
1-Newbie

QuickTags not displayed

We have 2 different types of documents, and the QuickTags list only shows up in one type.  What triggers when the QuickTags list is displayed?  I already have the Preferences option "Show Quick Tags on Enter" selected, and in our "chapter" documents, QuickTags work great.  In our "book" document, I get an error: "[A11131] Insertion of text not allowed in this context."  I'm not sure why <enter> is trying to insert text rather than bringing up QuickTags.  In order to insert a tag, I have to go to the Insert menu and select Markup.  That correctly gives me the context-sensitive list of allowable tags.  How can I get QuickTags to work correctly? 

16 REPLIES 16

n reading the help file you might try the enter key on the number pad. Are you using Docbook, it might be making the performance of the normal enter key. You might read quick Tags in the on-line help. It suggests that it might be a mapping issue. You might try using the enter key on the number pad of the keyboard and see if that works. It says docbook has some mapping conflicts.  I am sure you might get some other help here also

rdiaz
5-Regular Member
(To:rmcgarvey)

Another possible issue is that one document (the one that works) has a stylesheet associated with it, while the other doesn't.

When that happens, Editor uses dflt.fos to display the format.

In 5.3 and before, this wasn't an issue, and both would behave the same.  However, in 5.4 and later, the dflt.fos now has the quadding set to asis, which means it's trying to insert an carriage return when you hit enter.

Thanks, Rafael.  That sounds like a potential path to pursue.  I appreciate the suggestion.

ramgurusamy
4-Participant
(To:rdiaz)

Hi 

Even I face the same issue. Did you find any solution for this.?

Any help is appreciated.

 

Thanks

Ram.

rdiaz
5-Regular Member
(To:rmcgarvey)

Hi Randall,

Just following up on this to see how things have gone, and if you are still having any issue or questions on this matter.

Let us know if we can help.

Hi Rafael,

Thanks for the follow-up.  No, I haven't figured this out yet.  I already have a custom stylesheet for the doctype.  I found the dflt.fos in the lib folder and removed the quadding entry, but that had no effect.  I've also reviewed these articles but they are geared more towards situations where a custom stylesheet is not utilized.

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS48821

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS111865

In our situation, we have a Book and a Chapter doctype that both use the same DTD.  The stylesheet used is book.fos (which matches the name of the DTD).  How can I ensure that the documents that use the Book doctype also use the book.fos, or provide an updated dflt.fos (or similar) for the Book documents to use with QuickTags enabled? 

This sounds like the Enter key may have been keymapped to something else in one of your doctypes.

To see the user-defined keymappings for a doctype, open a document and enter the following at the command line:

     show keymap

To see system- as well as use-defined keymappings, enter the following at the command line:

     show fullkeymap

Another useful command you can enter at the command line:

     show cmdkeys [output=filename]

If Enter is mapped, you can enter the following at the command line to unmap it for the current session:

     unmap enter

However, you will need to review the startup files in the Custom directory to find the keymapping so you can delete it.

Note that Help information is available for all these commands.

Good luck!

Suzanne Napoleon

www.FOSIexpert.com

"WYSIWYG is last-century technology!"

Thanks, Suzanne.  I found the command Show Keymap All a while back and usually stick with that one, but it doesn't contain all of the system defined keys.  Using the Show Fullkeymap, I see that Enter is Enter.  The odd thing is that the QuickTags work fine in our primary Chapter documents, but not in the Book documents. 

You can enter the option command at the command line to see if the Quick Tags feature is enabled:

     eval option("QuickTags")

If "off" is returned, the following is needed in a startup file:

     set quicktags=on

Or maybe set quicktags=off is in a startup file and needs to be deleted.

Good luck!

Suzanne

TimPhelps
5-Regular Member
(To:rmcgarvey)

Do you have the quicktags variable set to "on" in your preferences?

Hi Tim Phelps - Yes, in the Advanced Preferences, the QuickTags preference is set to On.  Any other ideas on how to get this to work?

TimPhelps
5-Regular Member
(To:rmcgarvey)

Is the document that you are attempting to use Quick Tags with being edited as an ascii document?

If Arbortext Editor is editing the document in Ascii Mode, the Quick Tags cannot function.

Ascii mode is used when there is no DTD or Schema.

Thanks for still thinking about this, Tim.  We don't do any editing in ASCII mode...just in the regular XML editor view with full DTD validation.  Please let me know if anything else comes to mind.

TimPhelps
5-Regular Member
(To:rmcgarvey)

What style sheet are you using?

Is it the default stylesheet? If so, then this is not set up for quick tags.

We use a custom FOSI for styling, and that has worked great for many years.  Since we share the same DTD for our Book and Chapter documents, we just have one .fos file that is shared for both types of documents.  

ramgurusamy
4-Participant
(To:rmcgarvey)

I have a similar issue. Recently , we migrated from Arbortext 5 to Arbortext 7 . 

I have selected show quick Tags on Enter 

Inside Tools--> Preferences --> Advanced..

quicktags ,smartinsert both are on.

quicktags not working specifically for a particular AU and for a particular parent tag alone that too when we clone AU ..

It is working fine when i edit the existing AU. Problem is only when I clone or create a new AU.

 I am able  to get the context specifc tags by right click and Insert Markup.. But not by clicking Enter button.

Announcements