cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Want Viewable En and Em spaces

ptc-3122859
1-Newbie

Want Viewable En and Em spaces

Is there a way to make Arbortext Editor show em and en spaces as a special tag or an entity tag rather than just as the space at its correct width? I know when I use Format>Touchup>Hard Unbreakable Space from the menu, I get a visible _hardspace in the document view. I need some visual cue for ems and ens so at a glance I know which is being used. Thanks, Rita Graham
5 REPLIES 5

You may want to try the following: Open the command line with 'Tools > Preferences > Window > Command Line' and insert 'tag_display -global -full _en' and 'tag_display -global -full _em' Good Luck, Andreas

After inserting the command, I get an error: "[A11464] Unrecognized tag name: _em" Since the Em space is not a tag, it can't display anything. Besides, typing a command in the window will only solve the problem for one document. I need it to display for all documents.

Well, to be honest, I don't know what you mean with "em and en spaces". I'm actually modifing the editor, not using it. If you provide me with some "how to insert such spaces", i may be able to come up with a solution. Besides, the step from one document to all documents is really really tiny.

An em space is a unit of measurement about the size of a capital M in whatever font is being used. It is much like the em dash in width, but it is a way to have a uniform amount of space, for example, following a colon. The en space is about the size of a capital N, about the same amount of space as an en dash. Since they are blank spaces, they show up as blank space, but when in use cannot be distinguished from one another. We insert these into our content to not only have a uniform width between text, but also to keep some text together, like if you had "IRC Sec.[em space]5043" in the text, it would keep the word with the number so that if it's printed at the end of a line, the number wouldn't be on the start of a line without having the word Sec. with it. When we used a DTD for our content, we could declare the em and en spaces as entities and they would show up as a tag in the content. But since we now use Schema, that is not an option.

hi, i had a similar issue with thin spaces, so i have a search and replace in custom\doctypes\whatever\instance.acl to replace them with the   character entity

set charentdisplay=on

replace(chr(0x2009),' ',0x2070)

and this in custom\lib\charent.cf to display them as an open box

chars:
thinsp "Arial Unicode MS" 0x2423 unicode 0x2009 current "\hmode\kern.1666em|"

also arbortext is set to convert character entities back to unicode characters on save.

cheers karl

Announcements