cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Server Manager

SOLVED
Participant

Server Manager

I have one Pro E that has decided to "Break" itself this morning.

Whenever you launch Pro E it will now have No Server selected in Server Manager. It has always had our Product Point Server selected at startup before. Every other machine works just fine and nothing has chnaged on this PC in a while.

We are currently on Wildfire 5 M080 if anyone has some insight in to what might have happened. Or how to make it default to a different server at start up?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Server Manager

Hi Erik...

Have you tried checking the value of the config.pro option dm_remember_server on the user's workstation? If the user messed with his config.pro options, it's possible this was changed or removed.

The default is yes which automatically remembers the primary Windchill/ProductPoint server. But if this option has been toggled by the user, this could cause your problem. Let's face it, some users like to monkey with their config.pro files (which is okay if you know what you're doing). But some of them do NOT know what they're doing and they end up wreaking havoc.

Go into the Server Manager, right-click on your ProductPoint server name in the list and make sure Set as Primary Server is selected. Then check the status of that config.pro switch. See if this makes a difference. If not... maybe have the user check in all work, delete the server definition, and re-register the ProductPoint server.

We use Pro/INTRALINK which is basically a stripped down version of Windchill PDMLink. To really remove the server definition and wipe everything out, we remove the users' .WF5 directory (which is where we store the server config.fld file and the local cache). I'm not sure if ProductPoint has a similar structure or not. I only ran ProductPoint for one day- and even then I wasn't intending to! It installed itself with Mathcad... and I removed it right away. That's the full extent of my ProductPoint experience.

Please write back and let us know if this helped or not.

Thanks!

-Brian

3 REPLIES 3

Re: Server Manager

Hi Erik...

Have you tried checking the value of the config.pro option dm_remember_server on the user's workstation? If the user messed with his config.pro options, it's possible this was changed or removed.

The default is yes which automatically remembers the primary Windchill/ProductPoint server. But if this option has been toggled by the user, this could cause your problem. Let's face it, some users like to monkey with their config.pro files (which is okay if you know what you're doing). But some of them do NOT know what they're doing and they end up wreaking havoc.

Go into the Server Manager, right-click on your ProductPoint server name in the list and make sure Set as Primary Server is selected. Then check the status of that config.pro switch. See if this makes a difference. If not... maybe have the user check in all work, delete the server definition, and re-register the ProductPoint server.

We use Pro/INTRALINK which is basically a stripped down version of Windchill PDMLink. To really remove the server definition and wipe everything out, we remove the users' .WF5 directory (which is where we store the server config.fld file and the local cache). I'm not sure if ProductPoint has a similar structure or not. I only ran ProductPoint for one day- and even then I wasn't intending to! It installed itself with Mathcad... and I removed it right away. That's the full extent of my ProductPoint experience.

Please write back and let us know if this helped or not.

Thanks!

-Brian

Re: Server Manager

This was it! I guess he was working with PTC the other day and that got set in his config.pro, but he hadn't restarted ProE since then. I never would have thought to look for this setting...

Thanks for the help!

Re: Server Manager

I'm always happy when I take a shot in the dark and hit. Glad this worked for you!