cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Show/Erase Axis Model Annotations

Highlighted
Garnet

Show/Erase Axis Model Annotations

Hi Friends,

Can anybody explain me the logic behind "Show Model Annotations" in drawing mode.

I need to do some exercise with Axis in Creo 2.0 drawing mode. I have an assembly having lot of sub-assemblies & parts and when I do select general view in drawing and click on Show model annotations, Only few axis are visible not all.

Now instead of this I have also tried another method by selecting individual part in drawing itself and right click > show model annotation but bad luck.

I have also tried the model tree options as well but doesn't work.

Actually within the same part I am able to see few axis but not able to see which I want to show in drawing. Axis are not hide in model tree or anywhere.

Please come up with your suggestions.

Regards,

Yogesh

Tags (1)
20 REPLIES 20
Highlighted

Re: Show/Erase Axis Model Annotations

I have had the same problem. I haven't figured out the logic yet, but something about using a different filter when selecting seems to enable selection of the sub-level components axes, dimensions and other annotations.

Highlighted

Re: Show/Erase Axis Model Annotations

When I am inserting that particular part (add model) in drawing, It shows all the axis correctly but not for the existing part.

We need to really figure out the problem related to model annotation.

Can we get some PTC expert's suggestion any other idea ???

Highlighted

Re: Show/Erase Axis Model Annotations

"I have also tried the model tree options as well but doesn't work."

Have you tried looking in the layer tree as well, to check if they aren't hidden there?

layer.png

Highlighted

Re: Show/Erase Axis Model Annotations

I have checked, they are not hidden in the Layer tree.

Highlighted

Re: Show/Erase Axis Model Annotations

Yogesh,

if you can upload the part, then (I hope) you receive and answer very quickly.

Martin Hanak


Martin Hanák
Highlighted

Re: Show/Erase Axis Model Annotations

Martin,

Agreed , I can upload the part but the problem is not only with this part this is a general query as I am getting the same issue with many parts in several drawings.

Highlighted

Re: Show/Erase Axis Model Annotations

Not sure, but is this perhaps something to do with the configuration option show_axes_by_view_scope ?

Highlighted

Re: Show/Erase Axis Model Annotations

Hi Paul

I did not find such option in configuration list. Can you please explain in detail ?

Regards,

Yogesh

Highlighted

Re: Show/Erase Axis Model Annotations

I'm using Creo 2.0.

Go to the menus: File->Options->Configuration Editor

You can quickly find options by using the "Find" command - e.g. I look for: axes

show_axes_by_view_scope.png

If in your system, this option is set for "top_model_only" then the sub-component axes will not be available for selection by the show/erase tool.

Try setting it to all_sub_models (which is the default) and see if your problem goes away...

Highlighted

Re: Show/Erase Axis Model Annotations

Thanks Paul,

I will check tomorrow and let you know the results

Cheers !!!

Highlighted

Re: Show/Erase Axis Model Annotations

Hi Paul,

It is already set as "all_sub_models" in the configuration editor.

Highlighted

Re: Show/Erase Axis Model Annotations

Just to make sure, you tried to set the show_axes_by_view_scope option to "all_sub_models" and "top_model_only" and got the same result?

Then I'm not sure what the problem is. FYI, I use "top_model_only" option, and so axes do not show unless I specifically select the features or components:

show_axis_annotations_in_drawing_example.png

Highlighted

Re: Show/Erase Axis Model Annotations

Thanks Paul,

I have tried this but did not help me

Highlighted

Re: Show/Erase Axis Model Annotations

This solution was perfect for us, since it did not require us to select either features or objects separately.

In my opinion, the correct selection of a feature in a part or a part itself is the whole cause of this misunderstanding.

Highlighted

Re: Show/Erase Axis Model Annotations

It looks like the default option changed from Creo 2 to Creo 4.0! The default was "all_sub_models" so no need to be specified into the config, but now, in Creo 4.0 (M030), it needs to be specified since the default is "top_model_only"!

 

Add this line into the config.pro and the situation changes as it was in the past:

show_axes_by_view_scope all_sub_models

Highlighted

Re: Show/Erase Axis Model Annotations

If this is an older drawing, the problem may be that the axis have been shown previously and then erased. This leaves the axis in the drawing but hidden and it will not show when using Show Model Annotations. In the drawing tree expand the view datums to see if they are there.

Capture.JPG


Creo is an endless adventure: Always more to learn.
Highlighted

Re: Show/Erase Axis Model Annotations

In relation to erased axes, it's worth noting that if you have a vast number of erased axes that you don't want, generally as a result of having shown all axes in the assembly tree then only kept a few, you can delete them all in batch. To do this, go to the detail options dialog (File>Prepare>Drawing Properties>Detail Options), and issue the detail setup command delete_erased_axes, by entering 'user_command' as the name and 'delete_erased_axes' as the value.

Highlighted

Re: Show/Erase Axis Model Annotations

I do not see where I can enter the detail setup command. I am using CREO 2.0 and I have opened the detail options by clicking on change.


Creo is an endless adventure: Always more to learn.
Highlighted

Re: Show/Erase Axis Model Annotations

A detail setup command is done in the detail options dialog, using 'user_command' in the field where you would normally enter the detail option name, and the command (here, 'delete_erased_axes') where you would put the detail option's value.

Highlighted

Re: Show/Erase Axis Model Annotations

This worked in my case, many times.

Announcements