Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Your Friends List is a way to easily have access to the community members that you interact with the most! X

Cannot enter Product Code


Cannot enter Product Code

Hi guys. I downloaded the student version of Creo 2.0. Somehow I can't click on the field to enter the product code. Would really appreciate it if anyone can help me. I have an assignment due next week.


23-Emerald III

Can your professor or college IT department help you out?

She told me to download from here

I'm pretty sure the link doesn't matter, as long as you download it from PTC. A friend of mine, Tom, did and I just copied the win 32-64 DVD (4255MB) file from him because my internet is so slow. I registered and got the Product Code. Everything is fine up to that License Identification. Funny thing is some of my friends copied the same file from Tom and it worked just fine.

This license kinda problem also happened when I tried to activate AutoCAD online. But at least I could click on the Serial Number field and type/copy-paste in it. I bought my laptop in Germany, so the settings are german standard. I am now in Malaysia and when I tried to activate AutoCAD, it said, "This product cannot be registered in Germany". But after a few tries it worked. So I wonder if there is some kind of conflict.

I searched the forums including PTC Discussion. This problem has happened a year ago but the few solutions offered did not work for me.


you have to go to page and make Registration. After a couple of minutes PTC sends you an email containing Product code of Student license.

During Creo installation you need reliable and fast Internet connection !!!

Also I suggest to download full installation package (4GB). Do not use Web installer !!!

Good luck

Martin Hanak

Martin Hanák

this happens if you are going through a proxy server or if you have an unreliable internet connection.

Make sure you are plugged directly into the internet and that it is a fast and reliable connection as Martin said.

If you are trying to install it in work or at your college or university their proxy server might be filtering/ blocking the installation program from accessing the internet this makes the field unclickable. took our I.T. supplier a week to find what part of the proxy was causing this.

In the end they turned off the proxy for me and gave me a direct link so i could get it installed.

hope this helps


Message was edited by: Gary Chadwick

Thanks for the tip, Gary.

I live in the college hostel and I can't say the internet is fast and reliable. But Tom who downloaded it lives in the next block. And my friends all live in the same hostel. It works fine for all of them but a guy who has a laptop from 2003 and still uses xp. I have to say the problem is my laptop but I don't know what.

Business Continuity with Creo: Learn more about it here.

Top Tags