Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can subscribe to a forum, label or individual post and receive email notifications when someone posts a new topic or reply. Learn more! X

Default units in Creo 2.0


Default units in Creo 2.0

How can I change de default units in Creo. I tried to run the configure.bat, but it did not find the right files.



Since I posted this in error on a differentplatform... maybe it will help you:

Open the part or assembly and go to File/Prepare/Model Properties/Units - change

There are some config options pro_units_length and pro_units_mass

The idea is that you want to open templates that are already set the way you want, but File/Prepare/... will let you change it.

Thank you Antonius, but I want to know how to change the default. How to create a new part or assembly using mmks units sistem. Change units for each part or assemblies is very improductive and is very dangerous.

Okay, I just wanted to be sure what you are looking for.

Creo itself has no units standard. It is the part file or assembly file that you open that maintains this information.

When you open a new part, uncheck the "use default template" and a list of template parts opens when you click "ok".

These files are predefined with the units described. You will find the relative information has been set in their internal "option:" settings.

In order to do what you want, you want to make the default templates to be metric. Please go to file/options/configuration editor/-find- "template"

You will find template_drawing, template_designasm, template_solidpart and many more. You specify the path and filename for each template type you want to make default. You can point to a template file pre-defined by PTC or you can make your own.

Two things to note:

1. You can make your own custom template part that has all the "other" settings you want for your particular organization. In the past, we often defined a "start_part" or "start_asm" with the parameters we needed. Those can now be template parts.

2. Remember that these template_x options must be in the file that is read when you start PTC. Not knowing your level of understanding, there are several ways to manage options. My preference is using a desktop shortcut with a "start location" outside the Creo loadpoint. I then save my in that folder. It is best that customizations are not added to the Creo loadpoint only that you might loose this data during an datecode or version upgrade (I lost a lot of stuff the 1st time!).

Hope this all makes sense.

Thanks a lot, PDX. I got it. But is unbelievable how difficult is it!!!! I believe that it should be very more simple.

Oh, but it -is- simpler these days You should have tried this a decade ago!

Try this, it is much simpler: (it may not work - it did for me but I am using the academic edition)

So I had the same problem: I wanted to change the default configuration of dimensions/units of Creo Parametrics 3.0 but the configure.bat didn't work due to there were some files missing.

Basically, there are two other ways:

#1 Change single attributes and safe as

I found some ways to change the dimensions to mmks but that was für specific files only. As soon as I started a new instance of Creo Parametric 3.0, the settings were gone. What you can do is to change the following attributes ist to navigate to 'File' > 'Configuration manager' and then search for these attributes and change them accordingly:

pro_unit_sys         >    mmks

pro_unit_length      >    unit_mm

pro_unit_mass     >    unit_kilogram

You can safe it as your individual file in your working directory or wherever you wanted.

#2 Use/set default PTC

A way cooler way to change the default settings in the long run, which took me a while of browsing and trying out, is to select 'Import/Export' in the lower right hand corner of the 'Configuration Manager' and click on 'Import configuration file'. Then navigate to the PTC-folder. In my case/most of the cases it's:

C:\Program Files\PTC\Creo 3.0\M070\Common Files\creo_standards\config_files and select the '' file.

After this change, Creo uses/loads the as the default configuration while starting up.

As far as I can tell by now, that solved the problem.

Please give me feedback and let me know if this way worked for you, too!



Business Continuity with Creo: Learn more about it here.

Top Tags