Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Unable to start vendor: ptc_d.


Unable to start vendor: ptc_d.

I re-installed FlexNET because I had some problems and then the next error appeared.

Unable to start vendor: ptc_d.

It's not the first time I got it, Two times before: When I installed Creo 1.0 for first time and when we upgrade to 2.0 version. It was solved by an technician, but I'd like to do it by myself because I'd like to know what's going wrong.

If you had had the same error and then solved, please let me know how.

Thank you.



my suggestion ...

1.] Uninstall FLEXnet installed from Creo 1.0 or Creo 2.0 DVD (release 11.x)

2.] Install FLEXnet from ProE WF5 DVD (release 10.8.x)

Martin Hanak

Martin Hanák

Hai Martin,

When i started my carrier as AE i was Advised by my senior to avoid installing Creo 2.0(m020) flexnet version, instead of that he prompt me to Pro-E 5.0 dvd, as u suggested ,

As a Ae i have to handle System Admin too,they raised questions about this Scenario of Dual backup and Dual installation,

When after seeing your Suggestion about this Flexnet issue i have Self Compromised it Could be a bug,

But Recently M030 has been released,Does this bug have been Resolved,in this version ?

And i Eager to know What is the Relation between Server and User,

How its getting communicated and Time frequency?

How can we manage it ?

thanks in Advance


1.] I will use FLEXnet from ProE WF5 DVD (release 10.8.x) until PTC ends its support. I don't want to waste my time with testing new Creo 2.0 DVDs.

2.] I think you can find information about communication between Creo and FLEXnet at Knowledge Base

for example at

(see attachment)

Martin Hanák

You may also check if you have proper path to ptc_d.exe configured.

Go into Web Interface for Flexnet, click Administration in upper right corner and login with flexnet admin credentials into server (default is admin:admin). Then go into Vendor Demon Configuration tab and click Administer in line for ptc_d.

On that page, check if there is anything in section Vendor Daemon Location. It should have path to ptc_d.exe file (e.g. C:\Program Files\PTC\FLEXnet Admin License Server\i486_nt\obj\ptc_d.exe). If there isn't one, type the proper path, save the configuration and then start vendor daemon.

Also, what Martin said

thanks lukasz mazur,

i got it Rectified the Error posted over there,

When i tend to reread the license ,the problem was resolved,

But Actuaaly What is the mistake happened here ?

Can u Explain it if feasible !,,,

You mean, why license vendor stopped working and rereading license file helped? Beats me, to be honest With this new Flex server PTC introduced with Creo I had much more license system problems than with previous releases (usually server service simply stops and refuses to go back online) and still haven't found one proper procedure to fix it. Usually it involves restarting vendor, restarting whole license system, checking if vendor's path is properly configured, restarting whole operating system, reinstalling license server or going back and installing flexnet from Pro/E WF5 (usually the best solution ).

For example, I spent almost an hour today on the phone with my customer trying to get license server back online and it took two reinstallations and playing with vendor settings to finally got it working. The worst part is, I'm still not sure what exactly was the issue and why it didn't work after first reinstall.

Exactly my experience!

Business Continuity with Creo: Learn more about it here.

Top Tags