cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Flat pattern not working in Creo 2.0 sheetmetal

SOLVED
Highlighted
Newbie

Flat pattern not working in Creo 2.0 sheetmetal

I am not able to produce a flat pattern or unbend the part below, I have tried and have been successful in creating a simplier pattern however.

Are there limitations of the flat pattern tool which I am missing? Or a step I have obviously missed?

I have wateched a few video tutorials but can't spot what I am doing wrong. I have also attached the part file.

Also I am unsing Creo 2.0 student edition M090 if that makes a difference.

Thanks in advanceTail.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Flat pattern not working in Creo 2.0 sheetmetal

The usual reason for being unable to create a flat pattern is that the part is not of uniform thickness.

Check that all bends have inside and outside radii, that matching radii have identical axes. A double check is that the inside radius is the same value as the outside radius minus the part thickness. Also, radii must be constant along the bend.

View solution in original post

6 REPLIES 6
Highlighted

Re: Flat pattern not working in Creo 2.0 sheetmetal

The usual reason for being unable to create a flat pattern is that the part is not of uniform thickness.

Check that all bends have inside and outside radii, that matching radii have identical axes. A double check is that the inside radius is the same value as the outside radius minus the part thickness. Also, radii must be constant along the bend.

View solution in original post

Highlighted

Re: Flat pattern not working in Creo 2.0 sheetmetal

Thanks for your reply, I created the part using a blend with a thickness of 2mm and I ticked the option "Add bends on sharp edges" thinking this would add the required bends, however I assume now that it doesn't?

I just tried using "edge bends" but flat pattern still doesn't work. It also appears that atleast for the diagonal bend in the part the bend does not come out with constant raidus along it. Thinking about this now as I write, it is probably due my geometry and the angles of the sides changing along the length of the part.

I will try changing the geometry to get constant radius bends. Cheers!

Highlighted

Re: Flat pattern not working in Creo 2.0 sheetmetal

The likely problem with blends are the creation of warped faces. These will not unfold. Even if they are only very slightly warped.

Highlighted

Re: Flat pattern not working in Creo 2.0 sheetmetal

This is a tip I received from customer support on this type of problem. It helps visualize the surface to know if it is flat or not:

Hi Tom,

Here is what I found out from my investigation. The sketch from the bad part creates spline surfaces, where the sketch from the good part does not create spline surfaces.

You can see this by setting the config option mesh_spline_surf to yes and then setting the model display to Wireframe.

Highlighted

Re: Flat pattern not working in Creo 2.0 sheetmetal

Thanks for the responses! By changing my geometry a little so that the bend radius would be constant down the diagonal I am now able to create a flat ish pattern for it.

My next problem is that the pattern is not completely flat, as shown below. Are there any tricks to this?

Unflat+pattern.jpg

Highlighted

Re: Flat pattern not working in Creo 2.0 sheetmetal

Probably a similar issue.

The easiest way to make this kind of part is to start with a solid block in normal part mode and use the "convert to sheetmetal" module. it lets you shell the block to a common thickness and optionally add all the bend radii. Even doing this, you must much sure all the faces are truly planar.

Announcements