cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Adding a zero before a decimal dimension?

SOLVED
Highlighted
Newbie

Adding a zero before a decimal dimension?

Hello all,

How can I add a zero before the decimal when dimensioning a part in a drawing? For example, I am getting ".57" for a dimension. How can I make it appear as "0.57"? Is there a setting I need to get to to change this? Also, is there a way to make this a permanent feature, so I wouldn't have to keep changing it for every dimension on every drawing I make?

I am new to Creo, so forgive me if this is a silly question. However, I've been looking all over and can't find an answer. Please help. It is very much appreciated.

Thanks for your help,

Halle

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Adding a zero before a decimal dimension?

Hi,

You can alter this setting with "lead_trail_zeros" drawing option. When setting it to "both" all default dims should show with both leading and trailing zeros.

This one, and plenty of other drawing file options are stored in *.dtl file. To have a *.dtl file loaded into every new drawing you have to set a config.pro option called "drawing_setup_file" with path to this file.

There is also some sort of iso *.dtl file already predefined in the Creo installdir.

Hope that helps.

10 REPLIES 10

Re: Adding a zero before a decimal dimension?

Hi,

You can alter this setting with "lead_trail_zeros" drawing option. When setting it to "both" all default dims should show with both leading and trailing zeros.

This one, and plenty of other drawing file options are stored in *.dtl file. To have a *.dtl file loaded into every new drawing you have to set a config.pro option called "drawing_setup_file" with path to this file.

There is also some sort of iso *.dtl file already predefined in the Creo installdir.

Hope that helps.

Re: Adding a zero before a decimal dimension?

CORRECT ANSWER!

Re: Adding a zero before a decimal dimension?

I went into the iso.dtl file, and it read "YESlead_trail_zeros". Should I switch the "yes" to "both"?

Thanks for your help!

Re: Adding a zero before a decimal dimension?

Be careful with that, if it's per ASME, inch dimensions do NOT get a zero left of the decimal, but METRIC does. Also, 3-place inch dim should be shown as: ".050" whereas metric truncates a 3-place to not have a zero at the end, as in: "0.05".

You can change settings in Pro/E, but if it's supposed to be per ASME spec, make sure you have the settings correct.

Re: Adding a zero before a decimal dimension?

Thanks, I did not know that. All the companies I've worked for have used a leading zero. Is this a new standard?

Re: Adding a zero before a decimal dimension?

Sometime companies have their own standards that started with a prescribe standard like ASME or ANSI, but have modified it to their own likings and preferences. ASME and ANSI have been around for a long time.

Re: Adding a zero before a decimal dimension?

I use creo elements/pro 5.0 and in my drawings the dimensions linked to the model would not change to having a leading zero unless I changed lead_trail_zero_scope to all.

Re: Adding a zero before a decimal dimension?

I wonder if that was some kind of bug or other anomaly.

Creo 2.0 option... this one is from the model properties. The options are identical in the drawing setup.

lead-trail_zero.PNG

Re: Adding a zero before a decimal dimension?

In the drawing detail option file I've got the lead_trail_zero_scope set to dims, and the zeros show correctly.