cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Line display of quilts

Newbie

Line display of quilts

Hi There, I am currently doing screenshots of our products in wireframe (No Hidden). Some of our assemblies are ProE models but with some components imported (IGES files etc). When you select 'No Hidden', the ProE parts go to wireframe of visible edges only, but the imported componenets have all the lines on the model visible as if they are in 'Wireframe'. What I have to do with these parts is to import the model into a drawing, and then select 'Hidden line removal for quilts', and then the imported items appear as I want them in 'No Hidden' appearance. I then do the screen shot from the drawing. This is annoying, is there not a way to view imported items in 'No Hidden' mode without all the edges showing through? And the color of these imported components are purple instead of black edges, can you chnage this?
7 REPLIES 7

RE: Line display of quilts

I Have managed to change the line color from purple to black but changing the 'Quilt Edge' to black under 'System Colors'>'Geometry'. But still can't solve the stupid 'No Hidden' only works in drawings problem....

RE: Line display of quilts

seems to me the iges file came in with a bunch of seperate quilts and not just one quilt. thats your issue. it sees them as surfaces. if they were all one quilt you wouldnt see the back surfs. try importing a solid or start merging quilts i think. maybe someone else knows more. good luck

hlr_for_quilts set to yes

Can you change the config.pro option for hlr_for_quilts to yes. By default it's no and I think changing it will solve your problems.

RE: hlr_for_quilts set to yes

Try this Right click the imported feature id in the model tree, click on 'edit definition'. This will add 'features properties' in the edit tab on the top tool bar, features properties will show up, pick make solid, and see if solidifies, if all goes well you will get a solid part. If it solidifies you will get gray lines instead of the dark purple. Then try the hidden line.

RE: hlr_for_quilts set to yes

The Config option hlr_for_quilts set to yes solved the problem. Now when I have an imported model on screen and select No Hidden, the imported model displays only visible lines in black, which is what i wanted, cheers.

Control over individual quilt colors?

Along the lines of this post is there a way to individually control the color of quilted objects. The problem is that when one quilted object is a service part and one is phantom the only way to control the color is universally. Component Display will not override the color that has been set by the Quilt Edge in system colors. It’s all or nothing!? Our goal is to have the phantom parts be grey and service black. Any thoughts?

RE: Control over individual quilt colors?

Your request is a little more difficult. You could use the "edge display" option in the drawing to change the colors of the quilt edges to the standard grey, but you have to select all the quilt edges. The only other option I could think of would be to "solidify" the quilts if possible.
Announcements
LiveWorx Call For Papers Happening Now!