cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

How do I make a new coordinate system the active one?

vgillespie
1-Newbie

How do I make a new coordinate system the active one?

I am trying to move a part. The 3D copilot appears (I think that is what it is called, the 3d thing with the arrows and rings that you pull to move an object) but it wants to move the part in directions that are set at 45 degrees offset from the directions I need to move the part. I tried to see if there was a way for me to reorient the global coordinate system but could not find a way to do that. I created a new coordinate system successfully - but it has no effect on anything! What good is a new coordinate system if you can't move parts or measure relative to it????? I see no way to make it the active coordinate system. I looked through the help file and so far have not found a way to make a new coordinate system the active one.

 

I also tried creating a new workplane and then orienting it in the appropriate direction and then pressing F8 to show the coordinate system of that plane (which is oriented as I need it to be) but then when I go to move the part the 3d copilot is oriented according to the global coordinate system and not the one associated with the workplane. So that method doesn't work.

 

What am I missing here?

 

I am using Creo Elements/Direct Modeling Express.


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

i think you should check the Ref. Focus in the Position dialog box. its value is probably set to 'face'; change the value to 'All' and try to select the edge

View solution in original post

6 REPLIES 6

You don't have to use the 3D copilot as it appears. Once it appears you can click on faces, edges, workplanes, etc.. to reorient it.

Ok. When I click on a face the 3d copilot disappears and another related type of 3d moving device appears which operates only in the direction normal to the face I clicked. That will work well enough. Thank you.

That is still the 3D copilot. It will only display the available movements options based on what is selected. If you pick an edge you will see more options.

Ok. But it does not seem to allow me to select edges. But still this solves the basic problem I had before (I can now move a part with precision in a direction normal to a face). It does allow me to select cylinders, as well as flat and curved surfaces.

i think you should check the Ref. Focus in the Position dialog box. its value is probably set to 'face'; change the value to 'All' and try to select the edge

Ok. I tried that and that does help. Now I can apply the 3D Copilot to edges and corners and many types of places. That helps. Thank you.

Announcements