Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Resolving “Failed to load SQL Modules into database Cluster” issue when installing POSTGRESQL (windows)

No ratings

Error: Failed to load SQL Modules into database Cluster.

This error is usually seen during initializing the database cluster phase (in the setup as shown below).

To resolve this issue, follow below steps:

  • Create a PostgreSQL data folder before you start the installation (c:\postgres-data) and give full control for the user.
  • Select the newly created data directory during the setup.

After the successful installation, you can follow the remaining procedure for configuring it with ThingWorx from the respective installation document.


I had also this problem but the solution was not so easy as described above - always got the error.

Solution required for my machine the following steps:

1.)Uninstall PostgreSQL

2.)Delete the postgres user if it still exists :

net user postgres /delete

3.) Create the postgres user with a password you can remember:

net user /add postgres <password>

4.) Add the postgres user to the Administrators group:

net localgroup administrators postgres /add

5.) Add the postgres user to the Power Users group

net localgroup "power users" postgres /add

6.) Run a command window as the postgres user:

runas /user:postgres cmd.exe

7.) Run the install file from within the command window.


->his should run the installation successfully.

8.)Remove the postgres user from the Administrators group.

net localgroup administrators postgres /delete     

Hello Roland,

I tried this but still the issue persists.

Let me know if there is any other way to address this issue.



Same in my side, that didn't work for me. Did you find other solutions?

I solved this problem by creating the folder before the installation (C:\PostgreSQL\data) and giving it full access for the group "Users".

I am running Windows 10 enterprise, version 1709, OS Build 16299.371.


This seems to be problem with security. 

There is another solution if you want to use the default data folder,

  1. Installing with the default data folder.
  2. Making sure new data folder had full control access for the "NETWORK SERVICE" account.
  3. Then changing the default PGDATA folder as per this instruction:

I had a similar problem recently when installing Thingworx 8.1

The solution that worked for me 

a) used 9.4.x zip binary (

b) unzip the binary to a folder (this will be your postgres folder)

c) create a database cluster folder (data)  and a log folder in the above directory. Give full permission to the user 

d) initialize the database cluster

initdb -U postgres -A password -E utf8 -W -D <postgresroot>\data

e) If the above command runs successfully,it will end with the command to start the database.

(next continue with the installation document)

Version history
Last update:
‎Jul 25, 2017 01:50 PM
Updated by:
Labels (2)