Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you know you can set a signature that will be added to all your posts? Set it here! X

Troubleshooting ThingWorx Analytics – Common Issues in 8.2 & 8.3

No ratings

Continuing our series of Troubleshooting ThingWorx Analytics installations, in this IoT Tech Tip we will cover two items have been appearing for many users.


Error 1069 Encountered with Native Windows Installation of ThingWorx Analytics 8.2


In some instances, when a user successfully installs ThingWorx Analytics (TWAS) to a Windows Server operating system, they will encounter an error where TWAS will report an Error 1069: The Service did not start due to logon failure.


This can occur with any individual Service that is created by the installation, the following fix should work in addressing the issue.


Primary Reason This Happens:


This error can be encountered when the user provides incorrect credentials for associating the Services to an account during installation. In TWAS 8.2, there is a utility that will enable to the user to change the associated user on the Services. It is important the user provides the password for the User Account on Windows, and not the user/password combination for ThingWorx Foundation Platform Server.


Steps to Fix Issue


Solution 1:


Open a Command Prompt as Administrator, via Start Menu à Run à type CMD. Then right click on cmd.exe and Run As Administrator.


In the elevated command prompt, change your directory to the ThingWorxAnalyticsServer/bin directory, for example in the default installation path would be: cd C:\Program Files (x86)/ThingWorxAnalyticsServer/bin

Then execute the changeServiceUserAccount.bat <username>, for example: changeServiceUserAccount.bat user1


You will be prompted to change the password for the user.


Solution 2:


If Solution 1 does not resolve the issue, alternately you can manually change the Log On properties for each of the services. The changeServiceUserAccount.bat would do this via script, but on occasion this may work.

Open the Control Panel and navigate to Services, for example: Control Panel à All Control Panel Items à Administrative Tools


You will have to right click each individual service and go to Properties à Log On tab and enter the account name and password for the local account. Note: Local System account will not resolve this issue.


This issue was resolved in the ThingWorx Analytics Server 8.3 release, where all Services are associated with the Network Service account.



More information can be found in this Knowledge Article


Uploading of a Dataset hangs or does not complete in ThingWorx Analytics 8.3


On occasion, after a fresh installation of ThingWorx Analytics Server 8.3 on a Windows Server operating system, a dataset will not complete its upload. Typically no error message is displayed, and the upload wizard UI will just hang on the upload progress after:


Creating copy of Configuration File...

Submitting Create Dataset request...

Creating copy of Data File...


Primary Reason This Happens:


This is caused by twas-zookeeper service being stuck in a PAUSED state. This means that in the post installation, twas-zookeeper did not start.


Steps to Fix Issue


You will have to double check that the JAVA_HOME variable was defined as a System Variable. In the ThingWorx Analytics Installation guide, pages 12-14 outline the steps required as pre-requisites.

You can change this in Control Panel > System > Advanced Settings > Environment Variables, and ass a new variable named JAVA_HOME under System Variables. The value location should be the location of your deployment of JAVA software.


Typically this is located in C:\Program Files\Java\<jre or jdk>_<version number>



More information can be found in this Knowledge Article



i've added Java Home to the System Variables but the zookeeper is not running. If i try to start the zookeeper it says, "Windows could not start the twas-zookeeper service on Local Computer. The service did not return an error. This could be an internal Windows error or an internal service error."

How do i solve this problem?



Unfortunately the error message you reported is very generic.


Can you provide me the following:


  • Which Windows Operating System are you using?
  • What version of JAVA are you using?
  • Are you pointing to the actual JAVA.exe or the /bin directory?


Are you able to provide the install.log from your installation of ThingWorx Analytics?





Hello Neel,

thingworx analytics is running on a Windows Server 2016 Datacenter.

The Java Version is jdk.1.8.0_191. And i tired to point on booth, the .exe and the bin directory.

I'm sorry, i can't provide you my install log.


Kind regards



Without the logs, my assistance will be quite limited unless you open a case via the support portal (


Regarding the JAVA_HOME System Variable setting, it should point to where bin/java.exe is:


  • e.g. C:\Program Files\Java\jdk1.8.0_77\jre

Please verify that this is correct, also I can recommend that you review this Knowledge Article for additional information on confirming if this is indeed the core issue.





Hi Neel,

I attached the install.log. I followed the knowledge article - I've tested both Java_home and Jre_home, without success. However, I dont have the mentioned "AplicationLog.log" file anywhere on my Analytics server directory (attached screenshots).

I tried again a totally new installation of analytics 8.3.2 on another Machine with Windows Server 2012 RC2. But I still have the same result. I also tried it with domain administrator to all the services (following this article: Article - CS279460)




The application.log is part of Platform, you can find that in the Monitoring section of your Composer, or in /ThingWorxStorage/logs where your ThingWorx Platform Server is installed.


According to the Install.log file you provided, ThingWorx Analytics cannot connect to your Foundation Server.


Have you checked if the endpoint is correct? I am seeing two different Ports used in the Log File.


Is the Application Key current (not expired) and assigned to appropriate user?







Issue solved...

There was some copy-paste error in the java_home path.

I came back to this topic, as i found the file "...Thingworx_Analytics_Server\zookeeper\bin\zk.Server.cmd". Executing this, It told me direectly, that the java_home was wrong.

I thank you a lot for your persistant help!

Version history
Last update:
‎Jun 26, 2018 12:21 PM
Updated by:
Labels (2)