cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

KEPServerEx keeps disconnecting from Raspberry pymodbus

SOLVED
Highlighted
Level 6

KEPServerEx keeps disconnecting from Raspberry pymodbus

Hello,

I'm building the Sigma Tile solution. My KEPServerEx 6.4  keeps disconnecting from the Python Modbus server running on the Raspberry Pi. I figured out that the disconnection occurs exactly when the sequence number of the Modbus packets sent by the Kepserver to Pi reaches 256, hence likely the python server experiences kind of a 8bit data overflow.

 

Do you know how can I prevent the KEPServerEx from generating numbers greater than 255 to avoid this problem?

 

Much appreciated your effort.

Massimo

 

picture.png  

1 ACCEPTED SOLUTION

Accepted Solutions
Level 6

Re: KEPServerEx keeps disconnecting from Raspberry pymodbus

I just fixed this problem by installing the pymodbus 1.5.0.

It was reported as a bug few time ago upon 1.4 (link) and it was just fixed (link)

 

If the below command  gives you the 1.4.0 version of pymodbus

pip show pymodbus 

You have to install the 1.5

sudo pip install pymodbus==1.5.0

 

BR

1 REPLY 1
Level 6

Re: KEPServerEx keeps disconnecting from Raspberry pymodbus

I just fixed this problem by installing the pymodbus 1.5.0.

It was reported as a bug few time ago upon 1.4 (link) and it was just fixed (link)

 

If the below command  gives you the 1.4.0 version of pymodbus

pip show pymodbus 

You have to install the 1.5

sudo pip install pymodbus==1.5.0

 

BR