cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Odd Hole Pattern Issue

SOLVED
Highlighted
Newbie

Odd Hole Pattern Issue

I have created a hole pattern using the Point method in the dropdown menu (Pattern --> Point --> Sketch).  For some reason when I try to have the hole have a counterbore, the hole locations shift offcenter from the original sketch location.  Without counterbore it seems to be fine.  The pictures attached are me simply changing the hole type to/from counterbore.  I did not modify the sketch nor is there anything that would link back to it (that I have put in). 

 

I've had this happen before on other parts but it seems to be random.  I'm modeling this part in aircraft coordinates so the face is at an angle with respect to the original coordinate axes/planes.  Could this have something to do with the issue, even though relative to the surfaces all the features are perpendicular?

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Odd Hole Pattern Issue

Also note what version you are using.

In early Creo 2, patterns were a mess but I hadn't seen this specific problem.

What I do see all too often with less than stellar hole locations that the origin of the master patterned feature shifts.  It is easiest to find by looking to see if you have an extra hole or holes in the pattern.  The Pro|WorkAround^tm is to provide a specific origin when the option is available.

View solution in original post

4 REPLIES 4
Highlighted

Re: Odd Hole Pattern Issue

Hi Joseph,

I tried the issue on my machine, but could not see any issues with creating the Hole Pattern with Point and a Counterbore.  Could you please attach the models to the discussion to have a look at the issue?

How to upload Creo (or other) files

If you have maintenance and a SCN number, then I would suggest opening a case with Tech Support - Case Logger.

Thanks,

Amit

Highlighted

Re: Odd Hole Pattern Issue

Also note what version you are using.

In early Creo 2, patterns were a mess but I hadn't seen this specific problem.

What I do see all too often with less than stellar hole locations that the origin of the master patterned feature shifts.  It is easiest to find by looking to see if you have an extra hole or holes in the pattern.  The Pro|WorkAround^tm is to provide a specific origin when the option is available.

View solution in original post

Highlighted

Re: Odd Hole Pattern Issue

Hi Antonius,

I'm using Creo 3.0 but it seems your workaround was what I needed to fix the issue.  Thanks!!

-Joe Seymour

Highlighted

Re: Odd Hole Pattern Issue

Glad I could help.  If you ever see something funny about the black preview dots near the origin, this offset origin is likely the cause.

Please feel free to mark the answer as correct so others can find solutions.

Announcements