cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Button shows "Select Button States" in mashup

Highlighted
Garnet

Button shows "Select Button States" in mashup

Hello! Sometimes when loading a mashup I get text that says "Select Button States" instead of the radio button list (see attached). Refreshing the page will fix this usually after one or two attempts, though sometimes more.

 

My guess would be it is not initializing properly when the mashup is loaded. But that still doesn't explain the unpredictable behavior. Any thoughts?

 

I've seen this behavior on Thingworx 8.5.3 and 8.5.1

 

Connor

2 REPLIES 2
Highlighted

Re: Button shows "Select Button States" in mashup

Hi Connor

We have tried to create a sample mashup with Button Bar widget to check the behavior on our end on TWX 8.5.0 and we couldn’t reproduce the said issue. We have analyzed the har file, we couldn’t see an error as such on sending the requests. We have few points to check with you, please look below:

1. We can see from Bindings screenshot, that workOrderTypeButtonHighlight Output is mapped to SelectedValue of the Button Bar widget – could you please let us know which is this widget - workOrderTypeButtonHighlight and how is the mapping working and for what purpose
2. What is the frequency of the issue?
3. Is the issue specific to Chrome or IE?
4. Have you selected a State definition on Button States property of Button Bar widget?
5. Could you try clearing the browser cache when the issue occurs and check again if it reoccurs
6. Could you check the behavior after removing the workOrderTypeButtonHighlight mapping with Button Bar widget

 

Also I noticed below issue. Although it is different with yours, but you may refer it for setting permission:

https://community.ptc.com/t5/ThingWorx-Developers/About-radiobuttonlist-widget-Why-can-t-display-whe... 

 

Best Wishes!

Teresa

Highlighted

Re: Button shows "Select Button States" in mashup

Appreciate the quick reply.

 

1. See bindings screenshot attached. Although I'm not sure what workOrderButtontypeHighlight is? The buttonbar is bound to a button state that's a boolean. I'm am also seeing this on a mashup in a different project that has three button states.

twx_bindings_buttonbar.png

2. It's pretty unpredictable and seems to happen in spurts, it's been good this morning but was bad yesterday.

3. Happens on Firefox and Chrome, Firefox seems to see it less often

4. Yes

5. Clearing cache didn't fix

6. I'm not sure what the workOrderTypeButtonHighlight mapping is, can you clarify?

 

For the other post you linked, I gave all users read/write/execute permission and see the same.

 

Also, I am noticing that it happens much less when I reload the page via chromes refresh button, versus the thingworx Reload button next to show/hide debug info.

 

Thank you!

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!