Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

Give Group permission to CreateThing and DeleteThing


Give Group permission to CreateThing and DeleteThing


I want to give a group of users permission to create Things using our service. This service uses CreateThing and DeleteThing services. I gave this group permissions to


 but still I cannot achive to run this. 

I've got errors: 

[message: Not authorized for Delete]


[BaseStation1 CreateSensorNode] : Wrapped com.thingworx.common.exceptions.InvalidRequestException: Not authorized for Create Cause: Not authorized for Create]


BaseStation1 CreateSensorNode] : Wrapped com.thingworx.common.exceptions.InvalidRequestException: Not authorized for ServiceInvoke on CreateThing in EntityServices Cause: Not authorized for ServiceInvoke on CreateThing in EntityServices]

Can you provide me steps which I have to perform to allow group of users creation and deleting things using my service? Or at least objects/things/resources I have to change permission in? 


Strange thing - even with giving both runtime and designtime permissions to Instance another user cannot View Thing entity in Composer


Hi Mateusz,

You will need to give your user group collections permissions for Things. From the explorer in composer, hover over


and click on the permissions icon that appears next to it. Here you will add your user group to the design time permissions and grand proper access.

Thank you,



Hello Saeed,

I get this "Not authorized for ServiceInvoke on CreateThing in EntityServices" when i try to create things.

Referring to your post above, granted runtime and design time permission to the user on "Things Permissions". I can see my user at runtime and design time permissions tab. (Granted allow for all attributes).

I still get the above error on executing service.

Also i couldn't find my user at Entity service permissions tab(both design time and run time)

Please guide me




Many Thanks


Thanks, I was looking for permissions for Things Collection everywhere, but I omit this icon next to Things... Thanks.


Hi guys, to increase the reach of this simple yet critical question and answer the topic is converted to to a knowledge base article, please visit this link to view the article.



Hey Guys,

Saeed Manley

I tried this exact solution and it still does not let my user create new things. Any other solutions?

Is the user executing the CreateUser service directly or is the this entity service wrapped in a custom service? Have you already granted the user service execution permissions on the Entity Services resource. You may need to grant the System user service execution permissions on the Entity Services resource in order to allow other services to execute the CreateUser service.

Saeed Manley , I created a Helper Thing to wrap all of my service calls in. So, the user calls the service on the Helper Thing and the helper thing calls the entitiy service.

5-Regular Member

So, I suppose your helper thing user System User to run the service. Does the System user have all the privileges to run the service?

If the issue still persist please check the application logs using Administrator user and see if you find any error.

Top Tags