cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

MQTT support in ThingWorx

Re: MQTT support in ThingWorx

Finally I got this too working.

What I learnt is we need to change the runtime permission for services those need to be executed from the snippet.

e.g. if I am using

Things["EmailServ1"].SendMessage(params);

The runtime permissions must be allowed for Thing - EmailServ1. Please refer the image below.

ServiceExecutionFromMQTTSetting.PNG

Very happy having completed as this was the basis of one my imp PoC.

May be these settings are available by default and it is just me who missed them.

Nevertheless if someone is stuck like me, hope this would help them.

And of course thanks for the information in above thread.

Best Regards,

Amit Teli

Re: MQTT support in ThingWorx

Has anyone been able to configure TW5 to use RabbitMQ 3.5.6?

When I try to connect to the server I get an error

=ERROR REPORT==== 9-Nov-2015::11:15:49 ===

closing AMQP connection <0.298.0> (127.0.0.1:49887 -> 127.0.0.1:5672):

{bad_header,<<22,3,1,0,149,1,0,0>>}

Re: MQTT support in ThingWorx

Hi Graham,

AMQP is a different protocol than MQTT.... the log message doesn't mention anything about MQTT or related ports.

You should verify your client configuration, addresses, ports, as well as the server side that it is allowing MQTT connections.

To verify the MQTT connection, try using the HiveMQ online MQTT web-client posted above in order to be sure that your broker is visible and working on the Internet.

Cheers,

Greg

Re: MQTT support in ThingWorx

Can someone help me with the setup , I followed the exact steps and still it's not showing its as Connected.

What could have been wrong.

When i am testing through chrome mqttlens, its working fine. what am i doing wrong

Re: MQTT support in ThingWorx

Hi,

1 - Could you check if the MQTT extension has been correctly installed.
Go to Monitor (from the composer) and choose extension item and search for MQTT extension
If something goes wrong during MQTT installation you 'll be able to find some information.

2 - What is your operating system ? and the MQTT extension release ?

Re: MQTT support in ThingWorx

Have been able to figure out the issue.

Seems the extension on the marketplace is not working and as per the comment on other thread , need to download the below extension for which suppor tis requried.

http://support.ptc.com/appserver/wcms/standards/freefull_cs.jsp?&im_dbkey=162654&icg_dbkey=893

Can someone help if the above extension is available in public domain.

Re: MQTT support in ThingWorx

Hi Frank,

I have the same issue that the MQTT extension is not able to connect to my public mosquitto server.

MQTT_spy can connect without problem.

MQTT extension is also imported fine. I could not find any errors.

Any idea what I´m missing ?

Highlighted

Re: MQTT support in ThingWorx

Hello, In the meantime we understood that the MQTT extension was giving problems under Linux. MQTT extension on Thingworx Server running on Windows does not have any problems.

PTC offered a new MQTT extension begin of October and now the MQTT issue on Linux based Thingworx server is solved.

Solution: Use the latest MQTT extension from the marketplace.

Re: MQTT support in ThingWorx

hello Franck,

I tried the steps given but after publishing in mosquitto command promt I am not able view the temperature in thingworx. the isConnected service value is also false. I have given same serverName (test.mosquitto.org) and the serverPort (1883).

Can you suggest where I went wrong

Re: MQTT support in ThingWorx

while publishing itself i am getting error saying "unable to connect(lookup error)". can anyone help how to proceed further