cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

QueryImplementingThingsWithData stopped working

Level 7

QueryImplementingThingsWithData stopped working

I have a timer subscription that every minute runs a service that calls

     ThingTemplates["TemplateName"].QueryImplementingThingsWithData(params)

Suddenly the system started to give an error with this function. On the Application Log I read

     Wrapped java.lang.Exception: Unable to query implementing things : null Cause: Unable to query implementing things : null

this happened only in one ThingTemplate, with another ThingTemplate this service was instead working.

Noone was developing or connected into the system.

On Apache there  is only such request, just 1 minute after the error started, nothing else until some hours

     127.0.0.1 - - [22/May/2017:09:05:50 +0200] "GET /Thingworx/WS HTTP/1.1" 101 -

I just solved making a insignificant modification to such template and saving it.

I also removed the modification and saved again, and it continued to work.

So seems that this template was "broken" ... and saving it recovered its state

I have this setup

ThingWorx 7.3.4-b37

Server version:        Apache Tomcat/8.0.33

Server built:          Mar 18 2016 20:31:49 UTC

Server number:        8.0.33.0

OS Name:              Windows Server 2012 R2

OS Version:            6.3

Architecture:          amd64

JVM Version:          1.8.0_91-b14


Windows is running in a VMWare VM

note that few seconds before the error started, the system time was updated by vmware (seen on windows event viewer) , just synced of about 1 minute. This happen also other times but with no apparent issues ... May this cause troubles with internal timings ?


Has anyone an idea why this happened ??

4 REPLIES 4

Re: QueryImplementingThingsWithData stopped working

Hi Ivano Guerra​,

Did this issue persist through a restart of ThingWorx?

I only found one other case that reported the same error as you, and the root cause were Ghost Entities (https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS198580).  It's possible that the insignificant modification you made was enough to either remove a ghost entity, or make it irrelevant.

Regards,

Tony

Re: QueryImplementingThingsWithData stopped working

I've had this happen in TWX 7.3.  It was a bug with TWX that was fixed in a later dot release.  There was nothing that we could find which indicated what explicitly caused this to happen.

Re: QueryImplementingThingsWithData stopped working

hello

i have the same issue in 7.3.2 ( ThingTemplates["TemplateName"].QueryImplementingThingsWithData(params))

any news about this ?

Pascal

Re: QueryImplementingThingsWithData stopped working

You've probably encountered the same bug I did.  You will need to upgrade to resolve the issue.