cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Create Structure Element in Integrity 10.5

oostoia
1-Newbie

Create Structure Element in Integrity 10.5

Hi guys,

I'm trying to make a script which creates Structure Elements which have a certain name and content. When I run the im createcontent command the following error appears:

<?xml version="1.0"?>

<Response command="createcontent" app="rq" version="4.13.5479 0-0 5479">

<App-Connection port="***2" userID="username" server="hostname"></App-Connection>

<Exception class="ItemModificationException">

<Message>There are no valid state transitions for this item.</Message>

<Field name="exception-name">

<Value dataType="string">

<TokenValue>im.InvalidStateTransition</TokenValue>

</Value>

</Field>

</Exception>

</Response>

This is the exact command which I'm trying to execute:

im createcontent --hostname=hostname --port=port --user=username --type="Structure Element" --parentId=23549 --field=Content.fva="SW Testing" --field=Title.fva="SW Testing" --xmlapi

The exact command I use for creating Structure Elements on an Integrity 10.4 server and works just fine.

Does anyone knows why I get this behavior?

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions
KaelLizak
14-Alexandrite
(To:oostoia)

Hello Ovidiu,

  1. At first glance, I'd confirm that the Structure Element type actually can be created.
    • Can you do so from the CLI without using the --xmlapi argument? Can you do so from the GUI?
  2. Are there mandatory fields on the Structure Element type other than the ones you have in your arguments? Does the user ID you are using have permission to even see the type?
    • Check the output of im viewtype "Structure Element", and look at the Mandatory Fields & State Transitions, and Permitted Groups to confirm that information, possibly in conjunction with the output of aa users --groups username

I hope that helps.

Regards,

Kael


Kind Regards,
Kael Lizak

Senior Technical Support Engineer
PTC Integrity Lifecycle Manager

View solution in original post

2 REPLIES 2
KaelLizak
14-Alexandrite
(To:oostoia)

Hello Ovidiu,

  1. At first glance, I'd confirm that the Structure Element type actually can be created.
    • Can you do so from the CLI without using the --xmlapi argument? Can you do so from the GUI?
  2. Are there mandatory fields on the Structure Element type other than the ones you have in your arguments? Does the user ID you are using have permission to even see the type?
    • Check the output of im viewtype "Structure Element", and look at the Mandatory Fields & State Transitions, and Permitted Groups to confirm that information, possibly in conjunction with the output of aa users --groups username

I hope that helps.

Regards,

Kael


Kind Regards,
Kael Lizak

Senior Technical Support Engineer
PTC Integrity Lifecycle Manager

You were right, KaelLizak‌. It was a "permission related" problem ), but the error message was kinda ambiguous.

Thank you very much for your answer.

Announcements

Windchill RVS Users


Please take our

Windchill RV&S Authoring with Formula Editor Survey