cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - New to the community? Learn how to post a question and get help from PTC and industry experts! X

Error when creating an item of a new type

ptc-5210618
1-Newbie

Error when creating an item of a new type

Hi everyone,

I've just started working with PTC integrity and I encountered some problems when I was trying to implement my meta model. I was wondering if someone could help me solve the problem.

When I was trying to create an instance of a type I had made, I recieved the following error:

"MKS124606: Invalid state transition attempted for item 19814"

Here is the step by step description of what I've done:

I created some simple fields -e.g., portName[shorttext]- in "Integrity Client - Administration">Workflows and Documents>Fields,
and then I created a type- e.g., Port- at "Integrity Client - Administration">Workflows and Documents>Types.
Afterwards, I added the new fields in the "Visible Fields" of the new type.
Finally, I edited the type workflow, and added the state "Active" to the workflow and connected the state "unspecified" to the "active" state.

After creating the type, as I mentioned, I tried to to create an instance of it in the Integrity Client by following the steps below:

"Type" menu> "Create"->"Type Select".

Next, when I select the type -Port- and press OK, a new window-"Create Port" - opens. However, after filling the fields, and pressing OK, the error "MKS124606: Invalid state transition attempted for item 19814" appears.

I really appreciate your help.

Vahid Hosseini

3 REPLIES 3
JensN.
13-Aquamarine
(To:ptc-5210618)

Maybe you have to edit the self-transition-settings of this state. Mostly its the first state behind "unspecified", which needs to be edited.

Go to the Admin-Client, open your itemtype in edit-mode, look at workflow and right-click at the state-bubble. Then select "Configure Self Transition". In the next dialog-window you should select all groups you need.

kind regards, Jens

Thank you,


You are right, when I change the "Confugure Self Transition", I will be able to creat an item, without any error. But surprisngly, after creating an item, when I write a query to see all the items of the new type, it doesn't return anything.

Best regards

Vahid

I've seen this error when the State field is not visible on the new type. I run into this error quite frequently when setting up tests because the State is not visible by default on new types.

If the field is not visible, then you can't set any states. Configuring the self-transition on "Unspecified" would work around the problem because the State field no longer has to be changed.

regards,

Ann

Top Tags