Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

10.1 M050 end user Problems


10.1 M050 end user Problems

We update to M050 as we had problems with nightly restart after backups with 040. PTC informed us that M050 will resolve the issue.

I installed M050 on a test server and tested same again on Production over the weekend. I test on several machines with different configuration. No problems.

Monday morning key users had problems. Two problems, the Java Upload (drag and drop) was not working (and so browse did not work). I switched those users to Browse to upload files.

Problem two was a show stoppers. Doc Control could not see the Resulting Items section during Edit on the Implementation plan!

They could if they downloaded Chrome and used that - again no drag and drop.


UserIEJavaEdit Resulting ItemsJava upload file
Test 1116 update 45YesYes
Test 2107 Update 55YesYes
New96 Update 31YesYes
Robin96 Update 31NoNo
Sefka97 Update 55Yes (was on Java 6)No
James96 Update 31YesNo

Message was edited by: Ladric Grant


Can't you just disable the applet for uploading files and use the browser integrated upload ?
Preferences > Attachments > File Upload Mechanism

( i think one has to check the maximum file size )


Yes, that would be easy but the Calendar also uses the same Java and so no one can use auto- delegate  (its right before the holidays).

I was able to "fix" Robin's computer by backing up (zip) the "priv9.ser" file in Appdata and then deleting the priv9.ser file.

Clear temp files and cache on her computer and then she was able to see the Resulting Items section during edit on the Implementation plan.

What's frustrating with PTC is that they do not have a path as to what Java version will work. After a long call all I got was this version should work or that one.

I even have a users on Java 8 (IE 9) that doesn't have a problem.

We are switching all our users from Windchill and Agile over to Team Center by Mid-2016 not because Team Center is better, user like WC but supporting WC is a guessing game. It so unpredictable.

Hi Ladric,


interesting experience.  Maybe you want to share with the community ad contribute to the below discussion

There is a discussion about Windchill vs competitions




What client operating system is being used by the test systems and users you mention?

Also (although I don't think it causes the problems you have described), three of the users you list are using an update level of Java 1.6 (update 31) which is not supported for Windchill 10.1 M050.  Minimum supported is Java 1.6 update 45.

Do you have any thoughts on the reported facts that 1 user with IE9 and Java 1.6 u31 was successful with both operations; one such user was successful with one of the operations but not the other; and a 3rd user failed with both operations?  Are there differences in their client OS, or in the nature or size of the data they are working with?  And are the failures consistent and repeatable, or do they occur with seeming randomness?

Have the users who fail tried the same operations in a different browser (say Firefox) or in IE11?  If so, what were the results?   I don't know whether you are aware that, in mid-January 2016, Microsoft will end support for IE8, IE9 and IE10 on Windows 7 and later.  No more patches of any kind, including security fixes.   I believe IE9 will continue to be supported on Vista, until Vista's end of life.

Finally, is there a PTC Tech Support case reported for this problem?  If so, what is its case ID?


Karl Klapper

Product Management Director, PTC


With Robin, who is now "fixed" by removing the priv9 file from AppData folder. Cleared cache and it all worked perfectly.

Another users (Celia) was also not able to see the Resulting items or use drag and drop. Same "fix" using her normal 6 Update 45. She also had  7 listed in Programs.

For "James" we can see resulting items but still no Java drag and drop using 6 Update 45. So no calendar or process map. It seems that 6 Update 45 does not work. For "James" we have tried all versions of Java, clearing files each time. Annoying. Java 8 update 66 has come close to working!

"An exception occured in the JS API brwoseForFile().

Error name: TypeError.

Error message: Object doesn't support property or method "getTargetApplet"

Again, the guess is that to make M050 work is to use some version of Java and priv9 file!

For what its worth: PTC case 12862031. After a long screen share session the result was - something is not working with Java....


Just for some information I have IE 11 and Java 7 update 76 and it is working for me.  However, in Java 7 you have to add the IE address of PDMLink to the Security tab in the Java Control Panel.  It must be added to the Exception Site List.


Thanks Steve.

I update to IE 11 and then installed Jave 7 update 76. Cleared files etc etc etc and same results. No Java app so I can not see the workflow or use Calendar or another feature that requires Java.

I am now going to try IE 10 with Java 7 Update 55 as it works on another computer I have.

This would be much more annoying if it was not for the fact that I now expect this from PTC products. Can't wait to get off this. I updated to M050 because PTC said that would fix the issue with services not starting after backup - now users have lost functionality. What a cluster.


There is documentation that says Java 7 and IE 11 is supported for 10.1 M050.  We are on that build too.  I have several people with IE 11 and Java 7 U76 but most are still on IE 9 and Java 6 U38.  However, I have let IT know that any new computers can have IE 11 and Java 7.  Both of these (IE9/J6 or IE11/J7) are working but Java 7 seems to work better.  We were having trouble with the workflow template showing.  Once I upgraded to Java 7 it went away.

Just to make sure...the user did these steps?

Cleared the java cache.
Cleared out the temporary internet files.
Added the pdmlink address to the exception list.

For the benefit of others who have been looking at this thread, I believe this problem has now been successfully resolved with a couple of browser configuration changes:

  1. The Java Plugin on one of the machines had been disabled in the >> Tools > Manage Addons.   The plugin has now been enabled.  Without certain application code changes, Java applets cannot run in a browser in which the Java plugin is disabled.
  2. Windchill was a local intranet site so it was opening in the compatibility mode.  That option has now been disabled from >> Tools > Compatibility View Settings.   For the Windchill applets to run correctly, Windchill must be allowed to dynamically set the mode of the browser.

Perhaps Ladric can confirm that this problem has now been resolved without a Windchill code change.   I am also initiating a review of related PTC documentation, to ensure the completeness and accuracy of information that is relevant to this issue.

Incidentally, Ladric, now that you are on Windchil 10.1 M050, do services start up again after backup?