cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Actions Menu Bug? Need to refresh...

RocketMan
Newbie

Actions Menu Bug? Need to refresh...

Hi,

I've come across an odd but annoying bug and I was hoping someone else has seen it and knows the cause (or at least how to correct it!)

Per the attached photo, the Actions menu that shows up to the left of a part (when looking at a specific part) at the top left is, in fact, not in the top left whenever I first navigate to an object page. It is typically somewhere along the bottom left of the page, sometimes it shows in the table (often slightly overlapping with one of the "Actions" menus for a specific part), and sometimes it is far lower, as shown in the photo. Once I refresh the page, everything appears to be okay. This is consistent, as far as I can tell it happens whenever I navigate to a page where the actions menu is supposed to be in the top left.

This behavior didn't start until the last few days, but I've been using Windchill PDMLink 9.1 for 2 months now, so I know that something changed. Unfortunately I don't remember installing any programs just prior to observing this behavior, although I wouldn't be surprised if that was the cause of this. I thought it might be some add-on so I looked at them and disabled anything that appeared extraneous, but that didn't change anything (there weren't too many things like that anyway). I also thought it might be the version of IE9 I'm running but evidently I'm running a newer version than the one that's currently posted on Microsoft's download page.

Has anyone run into this before? I'm about ready to un/reinstall IE if I can't find a solution within a week! It's more frustrating than one would think!

Thanks!

2 REPLIES 2

Re: Actions Menu Bug? Need to refresh...

Does it do this in a different web browser? Same browser, different computer? Always the same user id? Different user id?

Is your system customized in any way?

Have you used a different computer with Internet Explorer to view the exact same output, but instead, view the HTML source (In IE, it is View ->Source) from the two systems and use a text compare tool to see if anything obvious stands out.

Lastly, I would clear your local browser cache and make sure you the settings for 'temporary internet files' is set to 'every time I visit the page'. If the problem still persists, shut the server s completely down and clear the tomcat cache.

Re: Actions Menu Bug? Need to refresh...

Thanks for the reply David, I didn't think to try on another computer. I did try different web browsers (chrome and firefox) and unfortunately the table on the lower half of the page never populates in either of these browsers. At least, this happens for me anyway, I don't know if that's typical but I've read of others having issues with running Windchill in Firefox and Chrome. As a result, I didn't think it would be an "apples to apples" test if other things don't work right anyway. Other users do not get that behavior which is what led me to think it might have been something I downloaded/installed that did it.

It's funny that you replied to my post because yesterday I noticed that it was fixed about halfway through the day - the first half of the day it wasn't. As a result, whatever change that was made took effect immediately, not after a reboot, but what that change was I'm not sure.

Thanks again for your help. If it comes up again I'll make more notes of the behavior and post back here in case anyone else gets the same issue.

Announcements