cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

CAD Worker Failing on Registering Server SOLVED

CAD Worker Failing on Registering Server SOLVED

Bang Head Here!!!!!!


Gurus, I've just updated my 9.1 M060 to M070 to make the move to Creo 2.0 next week.


We had a CAD publisher, on a seperate server,that was happily working prior to the upgrade and we were advised to update this to Creo View 2.0 M010 adapter and installed Creo 2.0 m020 on the worker server, now its all gone potty.


I've got everything set up and its creating the folders, everything looks like it should work but it seems to hang when trying to register the server for some reason, here is the job summary from publish monitor


27-Sep-2012 14:06:15:Start PublishJob: Assembly-215640a.asm,1.1
27-Sep-2012 14:06:15:"As Stored" Config Spec is available
27-Sep-2012 14:06:15:The EPMDocument As Stored Config Spec was selected as the default
27-Sep-2012 14:06:15:make temp dir C:\ptc\Windchill_9.1\Windchill\temp\pubtemp\publish9211975054782626609.tmp
27-Sep-2012 14:06:15:Start: Assembly-215640a.asm,1.1
27-Sep-2012 14:06:15:Authoring Application: Pro/ENGINEER
27-Sep-2012 14:06:15:empty temp dir: C:\ptc\Windchill_9.1\Windchill\temp\pubtemp\publish9211975054782626609.tmp
27-Sep-2012 14:06:15:Transferring Files to: C:\ptc\Windchill_9.1\Windchill\temp\pubtemp\publish9211975054782626609.tmp
27-Sep-2012 14:06:20:Number of Files (identified to be) Transferred: 174
27-Sep-2012 14:06:20:ProE Asm Conversion
27-Sep-2012 14:06:20:Added request to PROE queue
27-Sep-2012 14:06:21:Job 57 submitted to worker: dekwcworker-PROE:1
27-Sep-2012 14:06:21:LOGID: worker_5.log
27-Sep-2012 14:06:21: Registering Server


And there it sits until I stop the worker agent,


ProEPublish runs fine manually on the worker server so did I miss something or is anyone else having this issue


HelperLog shows: -



Logginglevelsetto0x001fromcommandargument.
[2012-09-2714:05:45]timestampsaddedtologgingfromcommandargument.
[2012-09-2714:05:45]workerhelper-Version:Creo2.0-M010(13.1.10.14)i486_nt
[2012-09-2714:05:45]Connectingtoserver"dekwindchill"onport5600
[2012-09-2714:05:45]Connectionestablished
[2012-09-2714:05:45]Startedworker
[2012-09-2714:05:50]Workerhasconnected.
[2012-09-2714:06:14]Passing$RUN$messagetoworker.
[2012-09-2714:06:14]Receivedworkertimeout:3600.


MonitorLog shows



2012-09-2714:05:44]workermonitor-Version:Creo2.0-M010(13.1.10.14)i486_nt
[2012-09-2714:05:44]Logginglevelsetto0x01.
[2012-09-2714:05:44]Connectingtoserver"dekwindchill"onport5600
[2012-09-2714:05:44]Connectionestablished
[2012-09-2714:05:44]GotINITSUCCESSreply
[2012-09-2714:05:45]Startworkercommand
[2012-09-2714:05:45]WorkerprocessstartedOk.


Worker Log shows: -


proe2pv-Version:Creo2.0-M010(13.1.10.14)i486_nt
Copyright(C)2000-2012PTC.AllRightsReserved.

[2012-09-2714:05:45]StartingProESmiley Tongueroe2pv-VersionSmiley Tonguearametric2_F000Creo2.0-M010(13.1.10.14)i486_nt
Copyright(C)2000-2012PTC.AllRightsReserved.

[2012-09-2714:05:50]Connectingtoserver"dekwcworker"onport2402
[2012-09-2714:05:50]Connectionestablished
[2012-09-2714:05:50]RegisteringasWORKER2dekwcworkerPROE
COMPLETE
[2012-09-2714:06:14]Recipefile:C:/ptc/creo_view_adapters/proe_setup/proe2pv.rcp
[2012-09-2714:06:14]Sourcefile:215640a.asm
[2012-09-2714:06:14]Outputfile:C:/ptc/creo_view_adapters/PVtransfer/w1i1j57/215640a_asm.pvs
[2012-09-2714:06:14]RegisteringServer:


And there it sits not creating the file although the folders are there


Help if poss please




5 REPLIES 5

CAD Worker Failing on Registering Server

Try running the worker test and send the logs.

Uncheck the “online” check box and hit the little blue “i” icon and it will do a self test. I’ve certainly seen this stuff before, just trying to dredge up some solutions.

[cid:image001.gif@01CD9C79.16F5DD40]

Steve Vinyard
Application Engineer

CAD Worker Failing on Registering Server

1- Windows Firewall?

2- Have the GS Daemon Service run under a specific Windows account rather than the system account.

3- Does your Adapter “test” run successfully from the Adapter editing utility?


[cid:image001.gif@01CD9C79.B0D2E700]

Steve Vinyard
Application Engineer

RE: CAD Worker Failing on Registering Server

Hi,


I got the same kind of issue. After several successful publishing the Cad Worker is stucking on aRegisteringServer... until I will restart Cad Worker.


Regards,


Emmanuel.

CAD Worker Failing on Registering Server

Chris,

We occasionally get this hung CAD worker with Pro/E Wildfire 4 and 9.1 M040. Typically it is a large assembly (like the log you show below). I don’t know if it might have to do with the number of files to be transferred.
I assume you get the same problem with a single part?

Here are some things I do to get things moving again.
On the CAD worker…
Stop the GS Worker service
Make sure you are not using the same PDMLink cache that you had before – if your setup folder is the same.
Delete the .wf folder and all log files.
Delete all the sub-folders from the shared folder.
Make sure the shared folder has the correct permissions
Run the proe2pv_config.exe and press the Test Server button
Review the recipe settings (we have set exit adapter after 30 conversions in the Advanced> System tab). This seems to help.
Run the proepublish.bat to see if Creo can publish a file manually.
Start the GS Worker

On Worker Agent Administration…
Uncheck the “On-line” check box and press the blue “test worker” button and review the results. This is usually the most informative, because I realize that I miss-typed something in the worker configuration.
Stop the worker and start it again
Check-in a simple test part and force a publish (if the check-in doesn’t trigger a publish)
Review the publish log and all the logs on the cad worker

I hope this helps.

RE: CAD Worker Failing on Registering Server - SOLVED

Big Thanks to all that replied


Turned out to be the FTP Username and Password, whether it hadn't saved it properly or what I've no idea but when I went to reconfigure the Agent it wasn't there, go figure!!!



Big thanks to Steve Vinyard from Tristar for his time and to the others that replied,


You guys make this forum!!!! and normally resolve quicker than you know who lol


Cheers again

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum! ______________________________ Check out the Windchill Tips Board! We're talking about Whirlpool's use of digital twin, augmented reality, and data-driven design!

The NAVIGATE WORKING GROUP is here! Come innovate with PTC!

Sign up for a Working Group