cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

CADWORKER not able to create directory during publishing process

Highlighted
Newbie

CADWORKER not able to create directory during publishing process

We are having issues this morning with some of the drawings NOT getting published on the cad worker. We are seeing the below error message when we look at the publish job summary. Note this is only happening to some users/drawings.


I did see the article (CS33760) on ptc.com and still confused on why some users are having problems and others are not.


We are using WC 9.0 M060 and Wildfire4



Thanks for the help.




Mar 4, 2013 11:25:46 AM:Start PublishJob: CAD Part - 74000114-06.prt, A.1
Mar 4, 2013 11:25:46 AM:The EPMDocument Default Config Spec was selected as the default
Mar 4, 2013 11:25:46 AM:make temp dir f:\ptc\Windchill\temp\pubtemp\publish54597.tmp
Mar 4, 2013 11:25:46 AM:Start: CAD Part - 74000114-06.prt, A.1
Mar 4, 2013 11:25:46 AM:Authoring Application: Pro/ENGINEER
Mar 4, 2013 11:25:46 AM:empty temp dir: f:\ptc\Windchill\temp\pubtemp\publish54597.tmp
Mar 4, 2013 11:25:46 AM:Transferring Files to: f:\ptc\Windchill\temp\pubtemp\publish54597.tmp
Mar 4, 2013 11:25:46 AM:Number of Files (identified to be) Transferred: 1
Mar 4, 2013 11:25:46 AM:ProE Part Conversion
Mar 4, 2013 11:25:46 AM:Added request to PROE queue
Mar 4, 2013 11:25:47 AM:Unable to submit job to worker
Mar 4, 2013 11:25:47 AM:Problem creating directory \\ama-graphlib\S_Worker\w1i1j15. Do not have write access
Mar 4, 2013 11:25:47 AM:Part Processing Returned: $ERROR$ Problem creating directory \\ama-graphlib\S_Worker\w1i1j15. Do not have write access
Mar 4, 2013 11:25:48 AM:CadAgent Returned: $ERROR$ Problem creating directory \\ama-graphlib\S_Worker\w1i1j15. Do not have write access
Mar 4, 2013 11:25:48 AM:End (with Error): CAD Part - 74000114-06.prt, A.1
Mar 4, 2013 11:25:48 AM:remove temp dir: f:\ptc\Windchill\temp\pubtemp\publish54597.tmp
Mar 4, 2013 11:25:48 AM:Publish Complete event dispatched
Mar 4, 2013 11:25:48 AM:End PublishJob (with Error): CAD Part - 74000114-06.prt, A.1

10 REPLIES 10
Highlighted

CADWORKER not able to create directory during publishing process

Hi Joe,

Graphics server configurations are notoriously picky when using shared file systems.

Switching over to the ftp: configuration will help, as it is also now the only recommended configuration on Windchill 10.1 systems.

Best Regards,
Carsten Lawrenz
Kalypso
Delivering on the Promise of Innovation
m. 415.378.6374

[cid:image001.png@01CDED9A.3684ED00]
[cid:image002.png@01CDED9A.3684ED00]<[cid:image004.png@01CDED9A.3684ED00]<http: www.facebook.com=" kalypsolp=">[cid:image005.png@01CDED9A...
wrote:


We are having issues this morning with some of the drawings NOT getting published on the cad ...

">http://ptc.com> and still confused on why some users are having problems and others are not.

We are using WC 9.0 M060 and Wildfire4



Thanks for the help.




Mar 4, 2013 11:25:46 AM:Start PublishJob: CAD Part - 74000114-06.prt, A.1
Mar 4, 2013 11:25:46 AM:The EPMDocument Default Config Spec was selected as the default
Mar 4, 2013 11:25:46 AM:make temp dir f:\ptc\Windchill\temp\pubtemp\publish54597.tmp
Mar 4, 2013 11:25:46 AM:Start: CAD Part - 74000114-06.prt, A.1
Mar 4, 2013 11:25:46 AM:Authoring Application: Pro/ENGINEER
Mar 4, 2013 11:25:46 AM:empty temp dir: f:\ptc\Windchill\temp\pubtemp\publish54597.tmp
Mar 4, 2013 11:25:46 AM:Transferring Files to: f:\ptc\Windchill\temp\pubtemp\publish54597.tmp
Mar 4, 2013 11:25:46 AM:Number of Files (identified to be) Transferred: 1
Mar 4, 2013 11:25:46 AM:ProE Part Conversion
Mar 4, 2013 11:25:46 AM:Added request to PROE queue
Mar 4, 2013 11:25:47 AM:Unable to submit job to worker
Mar 4, 2013 11:25:47 AM:Problem creating directory \\ama-graphlib\S_Worker\w1i1j15<smb: ama-graphlib=" s_worker=" w1i1j15=">. Do not have write access
Mar 4, 2013 11:25:47 AM:Part Processing Returned: $ERROR$ Problem creating directory \\ama-graphlib\S_Worker\w1i1j15<smb: ama-graphlib=" s_worker=" w1i1j15=">. Do not have write access
Mar 4, 2013 11:25:48 AM:CadAgent Returned: $ERROR$ Problem creating directory \\ama-graphlib\S_Worker\w1i1j15<smb: ama-graphlib=" s_worker=" w1i1j15=">. Do not have write access
Mar 4, 2013 11:25:48 AM:End (with Error): CAD Part - 74000114-06.prt, A.1
Mar 4, 2013 11:25:48 AM:remove temp dir: f:\ptc\Windchill\temp\pubtemp\publish54597.tmp
Mar 4, 2013 11:25:48 AM:Publish Complete event dispatched
Mar 4, 2013 11:25:48 AM:End PublishJob (with Error): CAD Part - 74000114-06.prt, A.1
Highlighted

CADWORKER not able to create directory during publishing process

I have this same error on a new Windows7-64bit publishing machine. The WinXP-32bit publishing machine works with no issues.
I have installed both PV12.1 and CreoView2.0 on the new publisher and both give the same failure to create directory error.

I am wondering if it is a folder permission thing since Win7 is more sensitive to this than XP was.


Thank you,

Ben H. Loosli
USEC, INC.
Highlighted

CADWORKER not able to create directory during publishing process

Try setting the Deamon to run under a user account (IT Service account). Also disable any and all UAC/Firewalls/Anti-Virus for testing purposes.

[cid:image001.gif@01CE18D8.B633E560]

Steve Vinyard
Application Engineer
Highlighted

CADWORKER not able to create directory during publishing process

I already run the Deamon under a dedicated service account. Win7 must be different than WinXP.

Thank you,

Ben H. Loosli
USEC, INC.
Highlighted

CADWORKER not able to create directory during publishing process

Hi Ben,

You have to run Windchill Method Server Instance and CAD Worker Service in same  IT Service account. Also ,please validate IT service account has read and write access on the shared folder location

 
Regards   
Ramanathan MK
India
9611 343094


----------
Highlighted

CADWORKER not able to create directory during publishing process

With Windows 2003 and WinXP CAD worker, we have never run them in the same name. The Windchill server services use the Local SYSTEM account for all Windchill, Apache, Tomcat and WindchillDS logons. The CAD Worker uses a dedicated SYSPDMAPP account. This has worked for years. When I try to switch the Windchill server to use the SYSPDMAPP account, the processes fail to start.

Now with Win7 CAD Worker, I can no longer create the directory.

Something is missing!

Thank you,

Ben H. Loosli
USEC, INC.
Highlighted

RE: CADWORKER not able to create directory during publishing process

Ben,


Windows permissions are always fun. It it isnot absolutely necessary to run both Windchill and the Daemon services as the same user. However, it greatly simplifies the permissions configuration when you do.


Ramanathan is explaining a recommended system administration practice. It is not a good practice to run Windchill relates services as the local system account for a few reasons.



  • JConsole or VisualVM cannot 'see' the Servlet Engine or Server Manager Javaprocesses when Windchill is running as Windows services using the local system account. If you use a different account these toolscan 'see' the Java processes. Granted you can work around this by calling out JConsole or VisualVM from the command line (Windchill shell).

  • Windchill connects to the publish temp folder using the credentials associated with the Windows service. So you must grant permissions for the \\<windchill< a="> app server>\SYSTEM account to read/write to the publish temp folder on the CAD Wo...

  • Using the Windchill service domain account across all servers in the Windchill configuration minimizes the number of usernames and passwords you have to remember to administer Windchill. Configure the Windows services to run as this account. Grant this account log on as service rights and use it for all cross-serverfolder mappings.


I understand you are in a secure environment and setting up a Windchill service account may not be permissible or possible according to your security policies. (I'm not sure if your secure network has the ability to set up domain accounts.)



  • You can try creating your publish temp folder on your CAD Worker machine through Windows Explorerfrom your Windchill aplication server.That means you must have an account on the CAD Worker that you can use from the Windchill server. The creator of this folder is automatically granted full permissions to the folder. This approachmay work in Windows 2008 R2 and Windows 7.

  • If you must have different accounts on the machines, configure the Windows services to run as the necessary accounts and then grant both user accounts read-write permissions to the publish temp folder.

  • Carsten's suggestion of using FTP is a viable alternative and will get you around not having a domain account. You can install an FTP server on your CAD Worker and configure the CAD Agent to use the FTP service.

Hope this helps.


Kind Regards,


Matt

In Reply to Ben Loosli:


With Windows 2003 and WinXP CAD worker, we have never run them in the same name. The Windchill server services use the Local SYSTEM account for all Windchill, Apache, Tomcat and WindchillDS logons. The CAD Worker uses a dedicated SYSPDMAPP account. This has worked for years. When I try to switch the Windchill server to use the SYSPDMAPP account, the processes fail to start.

Now with Win7 CAD Worker, I can no longer create the directory.

Something is missing!

Thank you,

Ben H. Loosli
USEC, INC.
Highlighted

CADWORKER not able to create directory during publishing process

Ben,
I had a similar problem. The finale resolution was to create another directory level so that virtual directory & the agent.ini file pointed to different locations. PTC had suggested that the Default Home dir in FTP be different than the Virtual Dir. But I didn't find that was necessary.

In FTP I have:
[cid:image003.png@01CDDC6A.3BD129E0]

In the agent.ini ( I have:
Windchill Machine Path: = ftp:\cad_viewables\quality
C:\ptc\cad_viewables\quality

Also if you are running https: the user running the GSWorker service on the worker machine has to be a real user, not local admin. Which is a pain, because every time the password has to change, you have to go to the worker stop the service and change the password for the user running it.

David Haigh
Phone: 925-424-3931
Fax: 925-423-7496
Lawrence Livermore National Lab
7000 East Ave, L-362
Livermore, CA 94550

________________________________
Highlighted

CADWORKER not able to create directory during publishing process

I was reading old email threads and found this one. Since I have the resolution that finally worked for me, I thought I would share it.

The shared folder on the publishing machine had to have it set so that the Everyone account can RW to the folder and its sub-folders.
Trivial solution but it is in the architecture of Windows and its security rights that changed from WinXP to Win7.
In WinXP all folders by default had the Everyone group with RW, while Everyone does not in Win7. Adding Everyone group to the list of users who had RW permission on the folder was all it took.

Highlighted

Re: CADWORKER not able to create directory during publishing process

Marked. This works for me.

Announcements