cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot delete or fix invalid PI in Intralink

Newbie

Cannot delete or fix invalid PI in Intralink

While running the healing scripts in Intralink 3.4 M030, one diagnostic message identified a PI object that had no PIV's.
(This healing is in preparation to migrating to Windchill Intralink 9.1.)

The model did exist at one time but had been deleted (all versions). Or so I thought.
Using the client I searched for the model, but nothing was listed.

I fired up Pro/E and created a model of the same name.
I had hoped to check it in and then delete it again.
As I suspected, the workspace Compare Status reported "Same name exists".

I tried to check it in. However, one of the conflict messages was not overridable.
" A master piv cannot be checked in to a replicated branch."

We do use replication, but do not use branching, so I do not know what this message means.
Any recommendation on how to delete this PI?

Gerry Champoux
Williams International

4 REPLIES 4

RE: Cannot delete or fix invalid PI in Intralink

Hi Gerry were you ever able to get this fixed? If so can you let me know what you did to fix it? I seem to be having the same issue right now and PTC is very slow to respond.



Thanks,

RE: Cannot delete or fix invalid PI in Intralink

Unfortunately, I do not recall what the solution was.
I thought I had submitted case to PTC, but could not find anything in the case history around that time.
I would assume that it should be easy to delete the no-longer-needed record(s) from the Intralink 3.x database.
Maybe that's what I did. It's more likely that I did nothing.
I suspect that since there were no PIV's for the orfan PI, there was nothing to migrate, and it became a non issue.



Gerry Champoux
Williams International
Walled Lake, MI

In Reply to Charlie Jones:



Hi Gerry were you ever able to get this fixed? If so can you let me know what you did to fix it? I seem to be having the same issue right now and PTC is very slow to respond.


RE: Cannot delete or fix invalid PI in Intralink

I had that thing happen in ilink 1 or 2 during upgrading. I ran the ilink_all_object report to determine the filevault name that cooresponds to the object. I then recreated the part with the filevault name. I manually placed it in the filevault. I later checked it out and fixed any proe relationships to its related assembly. checked it back in, and voilla fixed


Good Luck


Mark

Cannot delete or fix invalid PI in Intralink

Mark,



We once had the problem you describe, and fixed it in the same manner.

But that's not what the invalid PI issue is.
The PI is the top-level descriptor for an object.
It has few attributes other than the name.
The PIV is the actual entry that is associated with an actual file.

In a normally-working Intralink 3.x, there one or more PIV's for each PI.
When the last PIV is deleted, the PI is supposed to be deleted as well.

In our case, we had an orphan PI without any PIV's.





Gerry Champoux
Lead Engineer
Information Technology

Williams International
2280 E. West Maple Road
Walled Lake, MI 48390-3828

' (248) 960-2816

7 (248) 960-2607

* -

þ www.williams-int.com <outbind: 123=" www.williams-int.com=">




Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum! ______________________________ Check out the Windchill Tips Board! We're talking about Whirlpool's use of digital twin, augmented reality, and data-driven design!

The NAVIGATE WORKING GROUP is here! Come innovate with PTC!

Sign up for a Working Group