cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Copying a VM with a simple Windchill server already installed.

Highlighted
Newbie

Copying a VM with a simple Windchill server already installed.

Hi all,

I already have a Windchill instance installed on a standalone VM. the VM contains the Windchill server, PDMLink and the SQL Server database. In order to make my copy, I shut everything down on my source Windchill instance, and made a copy of the VM. I think used the "Windchill Rehost Guide" to reconfigure the new server with it's new server name. I refered to the section called "Changing the hostname in an Existing Windchill Solution."

The commands themselves seemed fairly straight forward. I did the following steps:

  1. I'm not using Vaulting or Replication, so I skipped that.
  2. My server is not connected to LDAP, so I skipped that step as well.
  3. I followed the command to update the Apache server
  4. I updated the Database as instructed
  5. I updated the Repisitory table on target database. I did the first part that updated the hostname for the local Repisitory. but the second part with refered to the LDAP servers and Info*Engine I skipped this to.
  6. Next I updated the Database connection configuration. Specifically the Hostname. the way I saw it, nothing else had to change.
  7. The next step was attempting to bring up the Windchill server. For what ever reason, I cannot login to the Windchill server, I receive the following error message:

"The system is not available. There could be a server error or your credentials could be invalid or expired (for example, you may have entered the wrong password or your account may be locked). Contact your help desk or administrator for assistance."

I have tried both my administrator account as well as student account I created on the original server, none seem to work. Anyone have any ideas where I should look next?

Regards.

Steve

3 REPLIES 3
Highlighted

Re: Copying a VM with a simple Windchill server already installed.

Your server may not be connected to Corporate/Enterprise Ldap, but Windchill comes bundles with a local Ldap server called WindchillDS. WindchillDS holds configuration information that Windchill needs in order to even start up. Since you skipped the Ldap rehosting, Windchill isn't able to find the necessary config info in WindchillDS for its new hostname, and is crashing on startup. If you go back and follow the instructions in the rehost guide to rehost the Ldap, then Windchill should start up.

You'll also need to go back and do the updates to the repository table that you had skipped. There will be entries for your WindchillDS Ldap in the repository table that need to be updated to the new hostname.

Re: Copying a VM with a simple Windchill server already installed.

Hi Chris,

One of the reasons I skipped over the LDAP step was because quite litterally I don't have an Ldap server to refer to. I defined server name and the fully qualified server server name within the local hosts file when I set up the original server.

I've been playing around with rehosting command as you suggested, but it crashes because I have no idea what to use in this situation.

ant "-Dtarget-ldap=ldap://administrator:<adminPassword>@spkwindgdn1.spkaa.com/" -Dtarget-domain=spkwindgdn1.spkaa.com

The error I get is:

C:\ptc\Windchill_10.2_next\Windchill\bin\adminTools\rehost\build.xml:63: Could not create type ldapUrl due to java.lang.NoClassDefFoundError: org/apache/log4j/spi/RepositorySelector

Also, as far as I can tell, I am not making further changes to the Repository changes than those I looked at above. The table itself has only 3 lines:

displayNameguidlastKnownDomainlocalcreateStampA2markForDeleteA2modifyStampA2classnameA2A2idA2A2updateCountA2updateStampA2guidWC
Windchill074500856-1407956499147-1465318690-32-100-16-172spkwindgdn1.spkaa.com12014-08-13 19:01:39.00002014-08-13 19:01:39.000wt.ufid.Repository112014-08-13 19:01:39.000U074500856-1407956499147-1465318690-32-100-16-172
NULLLdap.spkaa.comLdap.spkaa.com02014-08-13 19:01:41.00002014-08-13 19:01:41.000wt.ufid.Repository212014-08-13 19:01:41.000ULdap.spkaa.com
NULL680906748-1364429139245-598340657-243-13-253-132lestepp203d.ptcnet.ptc.com02014-08-13 19:07:55.00002014-08-13 19:07:55.000wt.ufid.Repository4825412014-08-13 19:07:55.000U680906748-1364429139245-598340657-243-13-253-132

I updated the DisplayName line as directed in the instructions, but I am not changing the domain name, so why would the second line need to change? I'm assuming it would still say Ldap.spkaa.com when I got done with the SQL command.

I'm assuming the last line is something best left alone.

Comments?

Highlighted

Re: Copying a VM with a simple Windchill server already installed.

If spkwindgdn1.spkaa.com is the target hostname of the system, then that command looks correct except for the the username. The username and password you should use in this command are the credentials for your WindchillDS admin user. The username is usually 'cn=Manager'.

Though, the error that you're getting when running the script is a NoClassDefFoundError, which is probably an issue with your environment rather than the command you're using.Make sure you're running the command from a Windchill shell. If you unset the ANT_ARGS variable before running the command, then try opening a new Windchill shell and running the script without unsetting ANT_ARGS.

For the repository, you're right that there aren't any more changes needed there. Since your LDAP entry doesn't include the hostname, and since the domain hasn't changed, the current entry will work with the new hostname without needing any changes.

Announcements