cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Generate representation for STEP file for WTDocuments

SOLVED
Highlighted
Newbie

Generate representation for STEP file for WTDocuments

Hi,

I am attaching STEP and IGS files as a primary content to WTDocument. I want to generate the representations.

I have added.

worker..DWG=DUMMY,preconverted=true

worker..TIF=DUMMY,preconverted=true

worker..BMP=DUMMY,preconverted=true

worker..PDF=DUMMY,preconverted=true

worker..STEP=DUMMY,preconverted=true

worker..IGS=DUMMY,preconverted=true

in wvs.properties file.

but not working.

please suggest.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Generate representation for STEP file for WTDocuments

  • Are you sure you put them in the correct place?  The location of the wvs.properties file changed in 10.2.
  • Did you restart the server after making the changes?
  • Did you try re-publishing any of these files after making the change?
  • Do you have automatic publishing enabled for WTDocuments (typically on check-in)?


Simply creating these properties doesn't make the files automatically show up.  They still need to be run through the publisher after these properties are created.

Here is the exact syntax I used for our 10.2 system:

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..DWG=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..DXF=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..PDF=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..BMP=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..JPG=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..TIF=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..GIF=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..PVZ=DUMMY,type=zip,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..EDZ=DUMMY,type=zip,preconverted=true

xconfmanager -p

View solution in original post

2 REPLIES 2
Highlighted

Re: Generate representation for STEP file for WTDocuments

  • Are you sure you put them in the correct place?  The location of the wvs.properties file changed in 10.2.
  • Did you restart the server after making the changes?
  • Did you try re-publishing any of these files after making the change?
  • Do you have automatic publishing enabled for WTDocuments (typically on check-in)?


Simply creating these properties doesn't make the files automatically show up.  They still need to be run through the publisher after these properties are created.

Here is the exact syntax I used for our 10.2 system:

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..DWG=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..DXF=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..PDF=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..BMP=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..JPG=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..TIF=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..GIF=DUMMY,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..PVZ=DUMMY,type=zip,preconverted=true

xconfmanager -t codebase/WEB-INF/conf/wvs.properties -s worker..EDZ=DUMMY,type=zip,preconverted=true

xconfmanager -p

View solution in original post

Highlighted

Re: Generate representation for STEP file for WTDocuments

Hi,

Its working now. There was problem with object adapter.

Thanks,

Announcements