cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Java out of date message

SOLVED
Highlighted
Sapphire I

Java out of date message

I upgraded to Windchill 11.0 m030 last month. Along with that we had IT upgrade Java to 8.144 and IE to 11.0.

Everything is fine except when I got to Vault Configurator. The Java applet opens and then says it is out-of-date and will not run. I have Java set for High Security and the server in the trusted host list. My Windchill system is not on the internet so there is no checking with Oracle servers for a later version of Java.

Does someone know how to shut off this data check and allow me to run the Vault Configurator?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Java out of date message


wrote:

I upgraded to Windchill 11.0 m030 last month. Along with that we had IT upgrade Java to 8.144 and IE to 11.0.

Everything is fine except when I got to Vault Configurator. The Java applet opens and then says it is out-of-date and will not run. I have Java set for High Security and the server in the trusted host list. My Windchill system is not on the internet so there is no checking with Oracle servers for a later version of Java.

Does someone know how to shut off this data check and allow me to run the Vault Configurator?


If you install CPS03 or newer the vault configuration UI has been changed to an html based UI so you won't have to worry about it for the Vault Configurator.

5 REPLIES 5

Re: Java out of date message


wrote:

I upgraded to Windchill 11.0 m030 last month. Along with that we had IT upgrade Java to 8.144 and IE to 11.0.

Everything is fine except when I got to Vault Configurator. The Java applet opens and then says it is out-of-date and will not run. I have Java set for High Security and the server in the trusted host list. My Windchill system is not on the internet so there is no checking with Oracle servers for a later version of Java.

Does someone know how to shut off this data check and allow me to run the Vault Configurator?


If you install CPS03 or newer the vault configuration UI has been changed to an html based UI so you won't have to worry about it for the Vault Configurator.

Re: Java out of date message

I don't normally do the CPS patches because of the environment we are in.

BUT, this will give me a reason to investigate this one.

 

One gatchas with doing a CPS?

 

Re: Java out of date message


wrote:

I don't normally do the CPS patches because of the environment we are in.

BUT, this will give me a reason to investigate this one.

 

One gatchas with doing a CPS?

 


I always put them on every month unless they are not supported for upgrade to the next release. ie 11.1 F000 will only upgrade up to 11.0 M030-CPS04. So for now I am stuck on CPS04 if I want to do test upgrades to 11.1 F000.

 

Installing a CPS almost 2nd nature now. However I have installed many cps's starting with 10.2 F000 and continuing to 11.0 M030. Key is to practice on a rehosted/cloned test server.

1. rehost production server to test

2. install cps on test - take notes

3. if no issues found then install on production using test notes as guide

 

The time to install a CPS which includes updating our replica file servers takes around 45min to an hr.

Re: Java out of date message

I finally put CPS06 on Windchill 11.0 M030 last night.

The HTML interface works fine....as long as I am on the server itself.

The HTML interface does not work when I do Vault Configuration from my own desktop. Is this a limitation of the HTML interface or something with IE cache.

When I select Vault Configuration, I get an IE page opened with 2 lines that say:

{{'global.sites_bar' | translate }}

{{ row.item.name }}

 

It is not a major problem as I can administer the vaults from the server but is this a known issue or something on my end?

Re: Java out of date message


@BenLoosli wrote:

I finally put CPS06 on Windchill 11.0 M030 last night.

The HTML interface works fine....as long as I am on the server itself.

The HTML interface does not work when I do Vault Configuration from my own desktop. Is this a limitation of the HTML interface or something with IE cache.

When I select Vault Configuration, I get an IE page opened with 2 lines that say:

{{'global.sites_bar' | translate }}

{{ row.item.name }}

 

It is not a major problem as I can administer the vaults from the server but is this a known issue or something on my end?


Most likely an issue on your end. The html interface works good for me on any computer I have used it on. I have used it with FireFox, Chrome, and even IE (just now...).

 

Make sure your IE browser is NOT set to compatibility mode:

https://www.ptc.com/en/support/article?n=CS203757