cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with EPMDocument and Vaults

Newbie

Problem with EPMDocument and Vaults

Hi,

1)

During the process of upgrade to 10.2, I had tried to remove vaults as they are from staging environment so eventually removed all from vaults from source database and then executed upgrademanager and it completed successfully. Now I am facing the problem like when I start I get lot of exception like below

" wt,fv,FvItem.456XXXX" does not exist. But I could able to browse the products , parts meta data without representations but could not able to open in creo as it fails to get the content.

Becuase of this inconsistency between database data and vault configuration, I am facing couple of issues as stated below/.

- not able to work on any part as it fails to open in creo ( cannot be retrieved )

- I could able to create a New EPM Docuyment but fails to open in creo

is there any way to clean bring both in sync, is it possible to reconfigure vaults points to source vault?

I can understand this for existing objects but for newly created objectes it is supposed to create proper entry in databse and in vaults and other operations related to that objects should work normally like download, opening in creo but those actions are not working for new objects also.

ABove is one problem ...

2)

I have another problem .. that is .. check out is happening from workspace but afte completion of operation it is not returning to workspace page , whell keeps on spinning .. but when I refresh the page I get workspace page with object in checked out state.

and the same operation is working fine form information page ...

all inputs are welcomed ..

Tags (3)
1 REPLY 1

Re: Problem with EPMDocument and Vaults

I had same issue during upgrade from 9.1 to 10.2. In my case, upgrade manager did not give option to upgrade vaults (which appeared to be as a bug). Anyways, I followed below procedure and it worked.

1. Login to Windchill as site admin. Navigate to “Site-Utilities-File Server Administration-Vault Configuration”

2. Expand Sites-Master-Hosts

3. You should see 2 entries below host. Delete target host entry. Rename source host entry to target host.

4. Validate vaults

5. Validate Replica Vaults

If you still face issue, open a PTC ticket to upgrade team and someone will help you over webex.