Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Windchill without WindchillDS


Windchill without WindchillDS

Hi all

Has anyone already installed Windchill with MS ActiveDirectory only, i.e. without WindchillDS, and then upgraded from 11.1?
Is there any experience you can share?


Best Regards



Accepted Solutions

Hi all.

PTC has published two new articles on the topic. - Knowledge HUB - WindchillDS Removal & Migration to other Directory Servers Windchill Directory Server (WindchillDS) removal starting Windchill


@MarkLobo Thank you for taking this issue seriously at PTC. I am sure that these articles will bring us further.

Best Regards


View solution in original post


We are in the process of trying this. No luck yet. 

Same here..

let‘s keep in touch 😉

I was able to update a test system to no problem.

Was not able to install directly.


I created multiple tech support cases with a screen capture of the exact part of the Solutions installer where one needs to select an existing LDAP install - no way evident how to select an existing Windchill DS.  Nothing in the install documentation and tech support so far has not been able to advise what to do.


We were thinking about going to but have backed off and will now upgrade (from 11.0) to and wait for to get more mature.


Pretty MAJOR change and very little from PTC on this.

So to clarify, you can go from 11.0 to 12.0.0.x to 12.0.1.x, but you cant go straight from 11.0 to 12.0.1.x?




Did multiple test upgrades from 11 to 12.0.0.x, but haven't yet tried going from 11 to 12.0.1.x.


23-Emerald IV

Not exactly the same scenario, but I'm running into all kinds of issues at the moment as well.


  1. Clean install of using Windchill DS from 11.2.  Fully configured with AD, etc.
  2. Ran upgrade manager to upgrade from 11.0 M030.  No issues.
  3. Repeated step two several times (fresh vault & DB copy, etc.), no issues
  4. Installed CPS
  5. Updated to
  6. Attempted to run the upgrade manager again (step 2) from 11.0 M030.  All kinds of problems.  Unable to get the upgrade manager to successfully finish now due to LDAP issues.

Tech support seems unable to figure out how to get the upgrade manager to work correctly with due to the new LDAP migration piece.  They are currently recommending I roll the whole thing back to, run the upgrade manager, and then re-update to again.  Not real excited about that...


So between the step 5 and 6 can you elaborate on the steps as its unclear at this point.

Perhaps from the details we may be able to figure out what's going on.. 


I tried again to do a new clean install of on a machine that already has (only) Windchill DS from 11.1, and cannot figure out how in the solutions installer to select the existing Windchill DS.

I created a new tech support case asking specifically what to do - not yet solved.

I think in PSI, if you treat Windchill DS as a v3 compliant LDAP and provide necessary details it will move forward.

I am doing the following right now:

  1. Installed WindchillDS from 11.2 .1.0 as standalone solution
  2. Installing  new clean install of
  3. Like Arpit-Singh said you select "Other V3 Compliant LDAP" and fill in the details
23-Emerald IV

@Arpit-Singh wrote:

So between the step 5 and 6 can you elaborate on the steps as its unclear at this point.

Perhaps from the details we may be able to figure out what's going on.. 

Starting condition:

Windchill fully configured and happy, but not live in production yet.  Need to execute at least two more successful upgrade manager runs before going live.  Previous upgrade manager runs occurred prior to updating the installation from to


Steps to refresh from production:

  1. Export the database from source (11.0 M030) and use it to overwrite the target (
  2. Export the LDAP from source, append it to LDAP from target, and then re-import the merged file to target.
  3. Fix the JDNI adapter names. (See CS337415 step 5)
  4. Copy the file vault from source to target
  5. Run the upgrade manager from Windchill shell
  6. Remove data from TableViewDescriptor table in the database. (See CS300564)
  7. Add missing translation preferences.  (See CS225163)
  8. Reset the GUID (server must be running, restart after changing)

Since the update to Windchill, the process is now dying at step 5 - run the upgrade manager:



By the way, Frank V. is the TSE with the case.

23-Emerald IV

The configuration branch on the source (running on the target) is most definitely there:





Okay, this make things more clear. 




What details did you put into the Source LDAP connection of UpgradeManager? Can you post a screenshot?

23-Emerald IV

The name of the target LDAP.

  • The new target server is intentionally blocked from accessing the original source server to minimize the risk of accidentally messing up the source system (which is still live in production.)
  • I followed the steps listed in CS337415.  Per that article, the name of the target LDAP is to be used in the upgrade manager:



To be clear, these problems are only occurring with  With and prior, no manual editing of the merged LDAP file is required.  The upgrade manager runs fine and completes successfully with no errors.  I actually rolled my installation back to over the weekend and re-ran the entire upgrade manager process.  No issues at all.  The problems only start happen after updating to


Thanks for the info Tom.



The above error you mentioned above is not expected. But as you mentioned let's have the investigation finished through that case and please update us once you know the cause. 

HI Arpit,


I hope your doing Good !!!!

I am working on upgrade Windchill 11.0 to 11.2.1

i faced below Error 


1. Fresh Installed Windchill 11.2.1

2. import the Database

3.import LDAP - 

I think its  not connecting the LDAP directory ... 

Can you please provide solution.

5-Regular Member


@Step 3
I think you are straight away importing the source LDAP to the Target
WindchillDS 11.2

*Note: you need to merge the source and target LDAP files and then import
the merged LDAP file in to target WindchillDS 11.2

Then you won't get the error.

Reference article-

Update your results.

Warm regards,
+91 8309337484



Thanks for the information and sharing the Article.


Let me try out and share you the feedback.

5-Regular Member

Hi Manjunath

Let us know if merging LDAPs worked?

We will see if there are any other workarounds if required.




Yes it Worked Venkat.


Started the Upgrade process.


Thanks for Your Support.




5-Regular Member


Work around was:
Launch Windchill DS control panel > Export ldap of Windchill 11.2 to source Windchill 11.0 > Re import the merged file.

5-Regular Member


did you edit the LDIF file before importing ?


Hi Tom,


 With and prior, no manual editing of the merged LDAP file is required.  The upgrade manager runs fine and completes successfully with no errors.


I am working on the Upgrade 11.0 to 12.0. Like you had said in above comments.


You had used the Existing Windchill DS of 11.2 and Run the Upgrademanager once done. Changed the JNDI Adapter settings on target server as per the Article CS337415.


For Windchill 12.0 and above , No need to Merger the LDAP file ? COZ after fresh installation of Windchill DS (Refer screen shot).

What are the changes to make before the upgrade process in 12.0 ?

Can you please suggest.


hello all,

I have given up on installing without WindchillDS....
The installation Windchill basically works, the users from the ActiveDirectory are also available. But the groups from the AD can not be found, although this is entered in the database in the table wtGroups, after a search of the users....
The PTC supporter has reported this to R&D, but so far I have no feedback on this.... Let's see how it goes on here.

I have now followed the following scenario:
- Install WindchillDS from
- Install Windchill with "other V3 compliant LDAP".
- Upgrade 11.1 M020 to
So far everything worked without problems.

I will now try to configure the system with ActiveDirectory and disable the WindchillDS.


It's a real shame that PTC can't support properly here.

I will get back to you when I have news.


So for me, I did a brand new install and configured WC 12.0.1 with AD.


And I can search the groups and users from AD


Here is my JNDI Adapter mappings:





Arpit: I read in PTC that json files will hold infoengine entries. Please help me with the location of these json files.

Also I do not see any url (Corporate Ldap) in the screen shot share above by you for.

We have gone ahead with the work around as below:

 1) Install WDS using 11.2

 2) Install 12.0.0.X

 3) Run upgrade manager and upgrade to 12.0.0.X

 4) Run update tool to update to 12.0.1.X


We need exact steps tp be captured in PTC article.


Yeah this is documented here. >


for quick reference > The Info*Engine configuration JSON files are stored in Windchill/IEConf folder. Path to this folder is specified by com.infoengine.config.dir property.


Also the Corporate LDAP URL is present in the info-engine configuration, its just that screenshot does not have it.

Dear Arpit

I have already installed Windchill several times and also tried various tests and configurations with PTC (CS15745873). I have escalated the case and it is currently at R&D.

For your understanding, in with following filter, I get the yellow warning symbol:


adding the Filter

at least the Windchill Licensing groups are visible, but no AD Groups



in 11.1 I have the following, and that is working:




@Arpit-Singh Have you also once tried to do an upgrade instead a new installation? The upgrade is horribly... No documentation at all to migrate the e.g. 11.1 WDS to 12.0.1 OpenDj,  ApacheDs, or even AD. You need to manually change server names in the ldif file, etc.  

Top Tags