cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

automatic JRE version selection

Highlighted
Newbie

automatic JRE version selection

We need to be able to run JRE 1.4 for PDMLink (8.0 M020) and JRE6 for
other apps/web pages. I'm thinking if the JRE version can be selected
based on the web address that would fix our problem.

For example, if the address is
5 REPLIES 5

automatic JRE version selection

Well since Windchill is frontended by apache and backed by its own tomcat instance, you could set up another application server and simply redirect different context roots there.

-Thomas R. Busch
Sr. Software Developer
Stryker Instruments
(269) 323-7700 x4014
tom.busch@stryker.com<">mailto:tom.busch@stryker.com>

automatic JRE version selection

One more thing - if you can upgrade to 8.0 M050 I believe it at least supports Java 5, which might give you enough of a compromise.

-Thomas R. Busch
Sr. Software Developer
Stryker Instruments
(269) 323-7700 x4014
tom.busch@stryker.com<">mailto:tom.busch@stryker.com>

automatic JRE version selection

The Java 6 Plug-In is supported with R8 as of M040, so one solution
would be to move to R8 M040 or M050.

For Java 6 Update 10 and higher in MSIE 6 and higher and Firefox 3 and
higher specific applications can select their own specific Java Plug-In
versions and each application will get its own version without
conflicting with others as in older versions. This only works for Java
6 Update 10 or higher JVMs to the best of my knowledge, though.

[As someone else noted with R8 M050 one can also run Java 5 on the
server for better performance, monitoring, etc, but that's a separate
and unrelated decision point.]

--
Jess Holle

automatic JRE version selection

Thank you to all who replied.

We found that it we simply uncheck the option below all works well.


David Graham
CAx/PDM Administrator


Emhart Glass Manufacturing Inc.
123 Great Pond Drive | PO Box 220 | Windsor, CT 06095-0220 | USA
Telephone +1 (860) 298 7377 | Telefax +1 (860) 298 7397
Mobile +1 (203) 376-3144 |

automatic JRE version selection

As noted on the R8 M050 platform matrix there are TAN's/TPI's on
getting Java 6 Update 10 and higher to work without unchecking this
option (which generally provides greater stability, higher performance,
etc).