Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Boundary Blend not going through curve


Boundary Blend not going through curve

I have a boundary blend: 2 curves in one dir, 5 in the other. This is a pretty simple problem: the surface I create does not go through the curves I pick. It tells me it does, and they highlight during feature creation, but when I accept the feature or preview it the surface doesn't go through it. See the attached pics.

Anyone got a clue as to why it does this and how can I fix it?

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

Without seeing the file it's a bit hard to tell.

Have you tried splitting into two different Boundary Blends, one with 2 curves the other with 3? I'd make the offending curve in your images the dividing line between them.

It may act differently depending on which one you do first too.

Doug Schaefer | Experienced Mechanical Design Engineer

Yeah, the file is pretty big with other geometry and is otherwise confidential at the moment, so can't upload it. I've tried splitting it many ways, dividing it into 2, 3, 4, 5 different surfaces.... By the end it was so ridiculously complicated that decided to start again. I was just wondering if there is some rule broken or whatnot, that might have caused this to happen. I put a datum point on the curve and measured between it and the surface and the distance was 0.3mm, on a feature that is about 100mm long. That's a little too much of a deviation from what it should be for my liking.

You might have a look at your accuracy settings. In general, I have lots of trouble with boundary blends but in your case, it might well be something simpler.

You might also consider a sweep or sweep blend option. You might have better luck with that.

Hi Grahame,

The thing about a boundary blend is that the system is trying to fit the surface into the constraining curves you've provided but there seems to be a limit to what it can do. Rather than trying to complete the geometry in one feature, you might try building your curve with the 5 going in one direction then trim the surface using the secondary curves. You can spend endless time fiddling with the tangency options and sometimes they can help. But in my experience, you tend to get better results by breaking the geometry up when possible. There might be a better solution but we really need a sample file to play with.

Antonius' comment about accuracy is definitely a good thought. If you crank the accuracy and find it still isn't enough, you can always reset the accuracy bounds to give you a greater range. Let us know if any of these comments help.



Regarding accuracy, do you mean making it finer?

Regarding breaking the surface up into smaller ones, or trimming the first surface... yeah, I spent all day yesterday trying that in different ways. It didn't give me a better surface, plus I wound up with a dozen extra features that made the model way more complicated and more likely to fail later on. Ugh.

I concur with both Brian and Antonius about the accuracy. I've noticed that the boundary blend became more finicky and less accurate starting with Wildfire. I get a lot of "the edges do not form a closed loop" nonsense errors. I know damn well they DO form a loop, because I made them that way, and even checked them, but it still fails. What used to be one of my fave tools is now almost worthless. I try and do everything like that with a VSS, and avoid the boundary blend whe possible.

Sometimes with these you just have to beat your head against your desk until you either find some Pro/WORKAROUND that works, or you pass out form the pain........

Best of luck!

Hello Grahame,

It's hard to tell just from these pictures. Did you try to play around with Control Points of the Boundary Blend feature?

Could you display a mesh on the surface, and provide a new picture with it? This mesh analysis is basically an U and V surface directions analysis, and you should find it under Analysis tab --> Inspect Geometry group --> Mesh Surface in case you are on Creo 1.0 or 2.0.

Eventually I got a good-ish surface, thanks everyone. I bought the part file a few drinks, talked sweetly to it and eventually got it to do what I wanted, more or less.

Every surface starts to look better just before last call