cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Decimal Places Disappearing in Drawing

cedroneg
6-Contributor

Decimal Places Disappearing in Drawing

Hello,

 

I am trying to create a drawing with dimensions in mm to 2 decimal places for tolerance purposes. I have one dimension which is 24.00 and when I set the number of decimal places to X.XX it displays 24 instead of 24.00. Does anyone know how I can fix this? I am using Creo 4.

 

1 ACCEPTED SOLUTION

Accepted Solutions
StephenW
23-Emerald I
(To:cedroneg)

There is options in the drawings setup (under FILE-PREPARE-DRAWING PROPERTIES-detail options CHANGE) that is probably removing trailing zeros.

In general, drafting standards for metric (ISO) say that you do not display trailing zeros.

View solution in original post

7 REPLIES 7
StephenW
23-Emerald I
(To:cedroneg)

There is options in the drawings setup (under FILE-PREPARE-DRAWING PROPERTIES-detail options CHANGE) that is probably removing trailing zeros.

In general, drafting standards for metric (ISO) say that you do not display trailing zeros.

cedroneg
6-Contributor
(To:StephenW)

If metrics standards say not to display trailing zeros how would I communicate the tolerances for those dimensions so they are +/- the standard +/- for X.XX in my drawing table? Instead of the +/- for X.X? If that makes sense

StephenW
23-Emerald I
(To:cedroneg)

It's been some time since I have used metric (iso standard) but I believe that you are not allowed to use that method to define tolerances. I may be wrong so someone who is familiar with recent ISO would have to confirm that statement.

BenLoosli
23-Emerald I
(To:cedroneg)

Trailing zeros are NOT allowed in dimensions for tolerance purposes on metric dimensions.

The method you need to use is to explicitly add the +- tolerance to your dimensions.

Reference ASME Y14.5-2009 section 1.6.1.

If you are using ISO 2768, you have your table that drives the dimension tolerances depending on your selection of class.

It doesn't seems to work, if I change it in any way it still doesn't show the zeros. Any other way to set it up?

StephenW
23-Emerald I
(To:Karolina)

If your drawing (or drawing template) is set up as ISO, you'll have to change related options in the drawing options so it is ASME. 

It would be easier if you attached a drawing/model so we could look at your file and try to actually help.

 

Ian_Cure
12-Amethyst
(To:cedroneg)

Has the dimension been "rounded", we recently upgrade to 4.0M050 and had a similar problem with an existing drawing where I couldn't get the decimals places to show.. Dimension in sketch had been rounded
Ian C
Announcements