cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

Displaying sketches and features

gemcoska
3-Visitor

Displaying sketches and features

So I'm brand new to Creo and am having a hard time with some basic functions.

 

It seems like every time I create a sketch, it displays in green when the sketch is selected but then is hidden when not selected.  Is that normal?  

I'm following a youtube video on how to wrap a sketch onto a curved surface and after I wrap the sketch, the sketch is hidden.  That part i get, since its consumed by the wrap feature.  The problem is, now the wrap feature is only visible when selected.  So when I go to project the wrapped curves, the curves are not visible.

 

A solution would be great, but also if someone can point me to and explanation of how working with sketches in creo should be approached, that would help me understand what is going on.

 

Thanks, 

Rob

11 REPLIES 11

@gemcoska 

Possibly layers are playing a role here. There might be a rule based hidden layer for curve or 3d curve, try switching to layer tree and unhide the respective layers to display the curves.  

Agreed with @Mahesh_Sharma layers may be at play.


Can you confirm you used a default model shipped with Creo as a start part?

 

Also what youtube video do you refer to?

gemcoska
3-Visitor
(To:remy)

I can get to about 1:55 in this video

When click off the wrap in the tree, the wrap disappears instead of appearing in blue.

 

I had looked at layers once but went back and unhid everything and it still didn't show up.  Then I had to open every folder and then unhid everything and they showed up.

 

Seems like a very clunkly way  to do things, is there a way to change the defaults for this?

 

Thanks guys

 

can you share the file? 

Pettersson
13-Aquamarine
(To:gemcoska)

It's a really weird setting in Creo. I've come across this before, but if you don't know about it, it's really hard to figure out. The sketch appears in wireframe, hidden and no hidden modes, but not in shaded modes, right?

 

The Creo config setting that does this is called "shade_width". It needs to be set to "curves". You probably have it set to "no". Here's how to change it:

 

  1. Go to File->Options->Configuration Editor
  2. You might be able to find the setting by scrolling in the list. Or you can search for it. Click "Find".
  3. In the "keyword" area, write "shade_" and hit Return.
  4. In the results, find "shade_with" and select it.
  5. It probably says "curves*" already as the value. Don't be fooled! For reasons only PTC knows, when you search for an option, it doesn't display your current value, but rather the default value. So just because it says "curves*" doesn't mean that's your current setting.
  6. Make sure it's on "curves*" and click "add/change", then "Close".
  7. If you look in your options list now, you should be able to find it. In the "Status" column it's probably a green star, telling you it's been changed. Click OK.
  8. Creo will ask you if you want to save the option. If you click Yes, you can save it to your config file and it will apply every time you start. If you click 2No", the option will only be active for the current session, and will reset when you restart Creo.

 

Hope that helps.

Pettersson
13-Aquamarine
(To:gemcoska)

It's a really weird setting in Creo. I've come across this before, but if you don't know about it, it's really hard to figure out. The sketch appears in wireframe, hidden and no hidden modes, but not in shaded modes, right?

 

The Creo config setting that does this is called "shade_width". It needs to be set to "curves". You probably have it set to "no". Here's how to change it:

 

  1. Go to File->Options->Configuration Editor
  2. You might be able to find the setting by scrolling in the list. Or you can search for it. Click "Find".
  3. In the "keyword" area, write "shade_" and hit Return.
  4. In the results, find "shade_with" and select it.
  5. It probably says "curves*" already as the value. Don't be fooled! For reasons only PTC knows, when you search for an option, it doesn't display your current value, but rather the default value. So just because it says "curves*" doesn't mean that's your current setting.
  6. Make sure it's on "curves*" and click "add/change", then "Close".
  7. If you look in your options list now, you should be able to find it. In the "Status" column it's probably a green star, telling you it's been changed. Click OK.
  8. Creo will ask you if you want to save the option. If you click Yes, you can save it to your config file and it will apply every time you start. If you click 2No", the option will only be active for the current session, and will reset when you restart Creo.

 

Hope that helps.

Pettersson
13-Aquamarine
(To:gemcoska)

I'm having a lot of difficulty posting my reply. It's being marked as spam by the forum for some reason. The solution in the option called "shade_with". It needs to be set to "curves". You probably have it set to "no". I'll try to get my full explanation posted.

 

---

 

Here's another try:

 

It's a really weird setting in Creo. I've come across this before, but if you don't know about it, it's really hard to figure out. The sketch appears in wireframe, hidden and no hidden modes, but not in shaded modes, right?

 

The Creo config setting that does this is called "shade_width". It needs to be set to "curves". You probably have it set to "no". Here's how to change it:

 

  1. Go to File->Options->Configuration Editor
  2. You might be able to find the setting by scrolling in the list. Or you can search for it. Click "Find".
  3. In the "keyword" area, write "shade_" and hit Return.
  4. In the results, find "shade_with" and select it.
  5. It probably says "curves*" already as the value. Don't be fooled! For reasons only PTC knows, when you search for an option, it doesn't display your current value, but rather the default value. So just because it says "curves*" doesn't mean that's your current setting.
  6. Make sure it's on "curves*" and click "add/change", then "Close".
  7. If you look in your options list now, you should be able to find it. In the "Status" column it's probably a green star, telling you it's been changed. Click OK.
  8. Creo will ask you if you want to save the option. If you click Yes, you can save it to your config file and it will apply every time you start. If you click "No", the option will only be active for the current session, and will reset when you restart Creo.

 

Hope that helps.

I got your response, thank you.  I followed your directions and it didn't quite fix the problems. See the below snapshots and the attached model.

 

Thanks,

Rob

 

Nothing on the tree selected

gemcoska_0-1579802841241.png

 

Sketch selected

gemcoska_1-1579802846416.png

 

Wrap selected

gemcoska_2-1579802850829.png

 

Layers - hidden objects

gemcoska_3-1579802855008.png

 

Patriot_1776
22-Sapphire II
(To:gemcoska)

In your original post you should specify what version and datecode of Creo you're on.  It may be a layers issue, or it may be "hidden" in the model tree.  If it's hidden, unhide it, and save the status....otherwise it goes back to hidden when you close it.

Pettersson
13-Aquamarine
(To:gemcoska)

As frank says, they're obviously hidden (you can see that because they're greyed out in the model tree). There can be two reasons why they're hidden:

 

  1. They've been manually hidden (right-click/popup menu an click "Hide"/the eye icon).
  2. They're on a layer that's hidden.

Looking at your layer tree, I see that there's a layer called DTM_CURVE and one called DTM_CURVE_SK (I think). I'm guessing these are "smart layers" that automatically collect curves, so whenever you create a sketch, one of these layers will automatically collect it. If this layer is hidden (which it looks like it is by default), then the sketch will not be visible.

 

Right-click on the layer and select "unhide" or "show" or the eye icon (depends on which version you're running). That should display the sketches and allow you to work with them. However, this status is not saved with the model, even if you save the model. Next time you open it, the layer will be hidden again. If you want to always show the sketch, you need to unhide the layer, then right-click in the layer tree and select "save status". Then save the model. This will set your layer tree's "default status", which it will return to every time you open the model.

 

The reason it works like this is because how the template file (also called a "start part") is set up. The template file has these layers, meaning any new part which is created will have them. This is used by companies to standardize their parts. If you want a different default behavior, you'd have to change the template file or use a different one.

 

Hope that helps.

There is another config option you could look at, Autohide_external_sketch. I think the default setting is yes, i have this set to no. This option could be responsible for sketches 1, 2 & 3 being hidden at least. They are external sketches to other features.

 

Good luck!

John 

Top Tags