cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Does anybody know why this is happening?

ghertyish
1-Newbie

Does anybody know why this is happening?

I have created a part which when halved looks fine: http://i.imgur.com/i26Qb5I.png?1, but when I try to mirror it something really screws up. This is what happens when immediately after mirroring: http://i.imgur.com/Uh4AkYB.png. This is what happens the moment I scroll in or out: http://i.imgur.com/oK2wW3H.png. I understand why the surfaces have mirrored but I don't get why the thickened walls just disappear. Does anyone have any ideas? I've uploaded the file though it's the student version so I think you can only open it if you have the student version also. (Also when I add the part to my assembly it still keeps this screwed up view).


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions
TomU
23-Emerald III
(To:ghertyish)

I just noticed something. The surfaces at the center of the model don't quite make it to the mirror plane.

5.PNG

If you create another datum plane slightly inside the model, cut with it (solidify), and then mirror from that plane, everything is happy.

6.PNG

I can't open your naitive model, but I think you may want to extend your surfaces past the mirror plane, and then either trim them off before thickening, or possibly trim the solid geometry after thickening.

View solution in original post

24 REPLIES 24

Another view of before it was mirrored to show how it should look from the side: http://i.imgur.com/SyZzWnm.png

It should also be noted that you can see through the walls from all angles: Top looking down:http://i.imgur.com/qHhQd2g.png, Bottom looking up: http://i.imgur.com/7tLUWaz.png

TomU
23-Emerald III
(To:ghertyish)

I wonder if it's a graphical thing. Try saving a copy as a step file and then bringing it back in just to see what happens. Also, maybe try increase your model accuracy and see if that makes any difference.

ghertyish
1-Newbie
(To:TomU)

I wondered if it could be graphical, I'm not running it on a PC but on a bootcamped iMac (21.5" one of the new thin ones) but I haven't had any problems before, it just seems to be this part. I tried the step file and when taking a cross section something even weirder happens: http://i.imgur.com/HZISIEk.png. It seems that where it should be hollow it has become solid and where it should be solid it is hollow. Increasing the accuracy seems to cause the model to fail.

TomU
23-Emerald III
(To:ghertyish)

If you're willing to share the file, I can test it here....

ghertyish
1-Newbie
(To:TomU)

The original file is in the original comment (though you need the student version of creo I think). Here's the step file:

TomU
23-Emerald III
(To:ghertyish)

You are correct, I can not open the student version. Can you upload a step file without the mirror?

ghertyish
1-Newbie
(To:TomU)

Here you go:

Increasing the accuracy has the potential to make more errors as the software can now see better. I often find that decreasing the accuracy allows Creo to smooth over errors that would otherwise cause problems. The ideal thing to do would be to model it perfectly but sometimes that isn't possible (part driven by another user's skeleton, import, etc.)

Possibly this is due to config option shade_surface_feat, make sure the value of this option is set as yes.

Where do you find that? These are the configuration settings I have: http://i.imgur.com/9O5RVkQ.png

Inoram
12-Amethyst
(To:ghertyish)

hit Find at the bottom.

Found it, but it was either already set to yes or didn't change anything unfortunately

Few test:

1. Change the display style to Hidden or Wireframe and check the results. Is it displaying complete body in Wireframe?

2. File > Options > Configuration Editor > Check all config files (.pro and .sup) for the specified option. You can check all files by selecting pull down for Showing. Config option shade_surface_feat should be only as yes.

config.jpg

Display.jpg

I've checked that and shade_surface_feat is set to yes but the problem is still there. Hidden and Wireframe show the broken model as well: http://i.imgur.com/uTd0Hev.png

I've seen this happen when Creo couldn't resolve the thicken at certain points so it resorts to "special handling" and basically turns the thicken off for those surfaces. If you make the thicken feature very thin or very thick, does it display properly? Something like a very small round that can't be offset by your thicken distance, a surface that has become inverted or self intersecting, surfaces that don't entirely match up, etc. Look at your geometry checks to see if there are any additional errors that you can solve before thickening or mirroring.

I think you might be on to something, reducing the thickness and then mirroring doesn't seem to help but mirroring the surfaces and then thickening them does. I can't get the 1mm thickness I wanted but it does let me thicken it to 0.8mm. Also solidifying and then shelling it seems to allow me a thickness of 0.8mm. I'll keep fiddling about with it but I appreciate everyone's input here. Thanks

TomU
23-Emerald III
(To:Mahesh_Sharma)

When I open the step file I do not see a double wall in the "rib" area, I only see a single material thickness.

1.PNG

2.PNG

3.PNG

ghertyish
1-Newbie
(To:TomU)

Is that the before mirroring step file? The thickness seems to be fine but then when I mirror it it seems to muck up.

ghertyish
1-Newbie
(To:TomU)

What happens when you try to mirror it?

TomU
23-Emerald III
(To:ghertyish)

Basically inverts. The same thing you're seeing. Solids become emtpy space and the space (sort of) becomes solid. Weird. If you don't have access to tech support, let me know and I'll submit it for you. I can reproduce this in WF5 and CP 2.0.

4.PNG

ghertyish
1-Newbie
(To:TomU)

That would be really useful thanks. What Eric Terrell said above may have something to do with it. I copied the initial surfaces from another model so that it would fit inside it and then ofset the surfaces so it would have some clearance distance. It is likely something is happening where some of those surfaces may be self intersecting and causing the error though I can't seem to fix it. I've managed to get a thickness of 0.8mm to work but I was hoping for a thickness of between 1mm and 1.5mm. If there is anything you could do I would be very grateful though leaving it at 0.8mm isn't the end of the world

TomU
23-Emerald III
(To:ghertyish)

I just noticed something. The surfaces at the center of the model don't quite make it to the mirror plane.

5.PNG

If you create another datum plane slightly inside the model, cut with it (solidify), and then mirror from that plane, everything is happy.

6.PNG

I can't open your naitive model, but I think you may want to extend your surfaces past the mirror plane, and then either trim them off before thickening, or possibly trim the solid geometry after thickening.

ghertyish
1-Newbie
(To:TomU)

Great spot, I trimmed it back slightly and remirrored on the original and it's mirrored correctly. I really appreciate the time you've put in to help me. Thankyou

Announcements