Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Your Friends List is a way to easily have access to the community members that you interact with the most! X

Measure Tool in Creo 2.0


Measure Tool in Creo 2.0

Hi everyone...

I know I've been absent quite a bit. I'm heavy into a very large design task and therefore I'm using Creo 2.0 very, very heavily. While I do prefer it to Wildfire 5... and even to Wildfire 3, there are some parts that drive me insane. I guess I just wanted to get everyone else's impressions as a sanity check.

The Measurement Tool in Creo 2.... how do you feel about it? I spoke to the developers in Anaheim about it and told them I did not like it. I tried to demonstrate some of the issues but I don't think they were "getting it". The implied notion they gave me was that I simply wasn't using the tool correctly. Instead of staying in "Summary", I should be using "Distance", etc. I went back to my job resolved to take another crack at it. Perhaps I was missing just how great the tool was!

Eh... no.

I've making measurements very, very frequently and I do not like the tool. I'll admit my opinion may be colored by fatigue. I've been working 16-18 hours a day (12 on weekends) and I'm putting in tons of time in Creo 2.0. Managers are all over me like bees on honey and I just can't seem to get ahead. But still, is it just me?

To be more uncharacteristically direct ... this tool is a festering POS and I want to do bodily harm to the people who've forced it upon me. The measurement window is always directly under the tool menu. Summary mode is bloated providing me with all sorts of information I don't even want. Distance mode is terrible. I'm clearly picking ON THE SURFACE OF THE MODEL and yet I'm getting edges and vertices 15 levels behind the surface I'm picking. I have to use custom filters, mapkeys, or other techniques to force the tool to do a simple measurement.

I also don't like that I have to hold CTRL to select the second surface. I never had to do that in previous versions because each selection was in a separate reference selector. Now I must use the Query Bin to get the correct surface (because of the problem mentioned about)... but I have to remember to hold down CTRL before I choose it else I lose my first reference. So the measurement process for measuring from plane-to-plane or surface-to-surface is:

  1. Step into Measurement Tool using Distance mode.
  2. Right-click on surface and select Pick from List.
  3. Locate surface in list and select it.
  4. Right-click on surface and select Pick from List.
  5. Locate surface in list.
  6. Hold CTRL key.
  7. Double-click surface in list.
  8. Move measurement window to view results.
  9. Resume work in Creo and get to the point where I need to use the value... but oops, I just forgot what it was (this really happens). I used to be able to see it in the message log but now I have to remeasure unless I wanted to save the measurement as a feature (which I don't).

I think the thing that bugs me the most about the CTRL thing is that many of the different modes and subsystems of Creo are not consistent. In one mode you need to hold CTRL, in another you don't. It gets horribly confusing which one requires the CTRL technique and which one does not. It's like the tools aren't testing for conformity across the entire product.

Also, I don't like the measurement box floating in space cluttering up my screen. The results window only appears if you open it? I'm taking a measurement, that should tell someone I probably care WHAT THE HECK THE RESULTS ARE. This could be mitigated though if the results were given in the message log like they used to be. But that has been removed. For the love of all that's holy WHY was this removed? Was anyone really complaining that the message log was impeding their work?

And another thing about the message log... I want to see more information in that blasted message log. Over the years PTC has steadily been removing messages from the message log. I can only speculate as to why. I used to write PERL scripts that pulled all sorts of relevant data from the message window. But now much of that data no longer appears at all. Again... why? Is anyone complaining that trail files are just too long?

Anyway this is turning into a rant and I didn't mean for it to be. I just wanted to start a discussion of the measurement tool and possible enhancements. What are your thoughts?

Thanks everyone...


At Wildfire 2,3, and 4 I just used a mapkey for measurements and I was happy... but of course all of my mapkeys were blown away in Wildfire 5 and then again in Creo 2 and I just don't have time to recreate them.


hi Brian,

I can send you some of my mapkeys for measure tool in Creo 2.0, if you'd like.

I agree with you on most of the things. I can't understand why is that the measurement window position keeps changing everytime a measurement is taken, and also why it tends to fly all over the place. Why would anyone let the programmers to make anything like that. Every second time it just hides under the main measurement summary window.

I am used to look at message log too, for recent measurement values, from other CAD apps. So, I tend to open message log every single time for that purpose even in Creo. It's annoying when I don't find there anything. The good thing on the measurement window is that you can copy the measured value using RMB menu.

One more thing that bugs me is that the measurement window fonts are very very small, and I couldn't find any way to adjust their font size. The shape of the font is also annoying, not really suitable for numeric characters I'd say.

Also it could be nice if the measurement summary window could be closed just with MMB.


I have to agree with you, Brian. When the tool doesn't even give you an X,Y, Z delta based on the default CSYS without picking the CSYS is absolutely wild. The dialog location and UI persistence are both very poor implementations. And don't even get me started on the "nearest" feature to the RMB click.

I'm sorry work is sucking up so much of your life, Brian. I've learned long ago that if you give 'em an inch, they'll take a mile, regardless of how much you "understand how important it is". Maybe they should have thought ahead and brought in some quality people a couple of years ago to fill the void (I'm available BTW ). I'm sure your pay didn't double when your workload did. I hope they honor comp time. Remember that American's tend to give away more work to employers than people from -any- other country.

Hang in there Brian. Hope to see you back here with your sage advice and scholarly solutions soon.

Solidworks infection,solidworks have simlar way of measure tool.

SolidWorks infection my eye! ...and I'm putting that nicely...The SWX measure tool gives you Delta XYZ and always has. I'm actually having to break out my calculator and subtract X1 from X2 to get delta X, etc. in CREO. This is 3D CAD 101 and I'm dumbfounded at the oversight.

This can be done without your calculator. See the image below. After you pick the two pionts, you need to activate the Projection collector (outlined in red) and hold down the control key as you pick the CSYS you want to use for your x,y,and z components.


tilll creo elements/pro 5.0 there used to be blue,red and green lines..showing the different coordinate measurements....why were they removed?..they were very very helpful...


I think the measure tool is the best tool I have ever seen! I like it soo much that I am trying to avoid using it. The best feature it has is that hide-behind-window, so I can play hide and seek everytime I use the tool. When I get tired of this game I just start playing "click on me to see the measured value" game and I love it.

CTRL button is really OK. It should be there. So software knows which two features are selected and measured from. But it does not work the "right" way, or we do not know how to use it. I should have been able to select multiple features and show only dimensions "connected" with CTRL button.

I find the measure tool a big enhancement. I love that in 3 clicks (measure, pick item, pick item) I've got a summary of information about those two entities (I rarely use the specific tools, the summary tool does all that I need). I like being able to display the results in alternate units. I do agree that it has its quirks. The biggest is not being able to expand the results window by default. I've gotten accustomed to the ctrl key requirement.

The selection quirk you mention his very frustrating, but it's not exclusive to the measure tool and it's not new with Creo 2. It's been that way forever. Personally, I'd like to be able to toggle through the selectable items under my mouse as they would be found if I passe through the model. It seems that edges & vertexes get priority when surfaces are what I typically want. (You can set the selection filter to surfaces, which helps). It also seems that the order of the query select is different in different modes.

Oh, and you also said " It's like the tools aren't testing for conformity across the entire product." That's absolutely true, and mind boggling. A few years ago I pushed to be a part of the technical committees primarily to address cross module inconsistencies like this. I asked which committee worked with the part of PTC concerned with that. I was told that there is no top level UI oversight, each group does what they feel is best for them. That's why the MMB does so many different things (shameless plug - vote for my enhancement to fix that.) among other things.

Doug Schaefer | Experienced Mechanical Design Engineer

In my opinion this meaure tool is great! So many information by having 1 or 2 clicks or more if needed. The big problem is the the big changes between wildfire xx and Creo 2.0. It took me a while to full understand how it works but when i did, i don't want to go back again

Feature tab is completely hidden,this is one more drawback.


i do like that blue "i" button that gives that cool pop up window with the results.that deal has saved me a ton of scratch paper.

[the noise of trees clapping for creo]

Thanks to talk about the blue "i", I like it too. After you save the measurments, you can find them in analysis, it is good to display or hide the measurements as drafts.

Hello Brian,

I admid that my enthusiasm about the changes was pretty small either.

Mostly it was because it did no longer work the way I was used to it. But I found out that it is not worse, just different:

  • Since I select with query select or from list most of the time anyway, geometry selection did not make much difference for me. I agree that it must be harder for those who work different. You will surely need the filters more often.
  • Before, I was used to click one reference in the dialog to replace it -> Now I click onto one item to remove again it and then the new one or I use RMB > Replace in the dialog
  • Before, I didn't had to press the CTRL button to select a second reference -> Now I have to, but it doesn't hurt much (not as much as an extra click would) and it is more consistent with the selection process in general
  • Previously I first told what type of measure I want -> Now I get a summary for me to use what I am interested in or I select it by RMB > Measure
  • And yes, I also liked to copy from the message log -> Now I select what I need in the summary and use RMB > Copy

As for why it has been removed: An internal SPR has been opened by Technical Support to check, why this happened. However, I believe the answer is rather obvious:

Instead of a single measure we are now getting a bunch of them in the Summary, so it is no longer so easy to output the result in a single line. And we already get the summary for the first selection. The second selection changes the output. So this would be quite some information, possibly cluttering the log.

Anyway, I have asked R&D, whether they want to consider adding a option to output summary information to our message log (people from Technical Support love the logs, as they often provide answers to querstions)

Are there any rogues at PTC that use SolidWorks for comparison? To know what they're competing against? Please look up a youtube video on using SolidWorks measure. You'll find that Creo is asking users to jump through many extra hoops to get the same results. Just the long click RMB you mention takes so much extra time. Please check out a video!


We still haven't made the giant leap to releasing work through Creo even though we have a lot of time spent in learning the software.

I have a couple comments to add to the discussion.

1) Without question the measurement tools are confusing to learn; sometimes you wonder whether you can even get from point A to point B. In the software we are replacing it is so simple and straight forward to get measurements. Why do they add so many layers of confusion?

2) Why is it that you don't see feedback in discussions like this from the product developement team. Brian is totally dependent on this software; and he represents many seats of Creo. At what point does the developement team care about how people actually use the software and why it is considered so unintuitive?

I like threads such as this as there are good ideas in how to make the best of confusing tools within Creo.



Look at how many users are complaning out LOUD about this tool. A few. Therefore, no one from PTC will even blink their eye because of us. If the number would be at least 1000, then they would start listening. Until then, we have to live with it, like it or not.


I guess one of the dissillusioning things we ran into when making our switch was thinking that a company with greater resources such as PTC would equal greater responsiveness.

I do hope better days will follow.

21-Topaz II


I'm interested on why you find this tool confusing. It's extremely simple to me - select measure, select item one, hold ctrl & select item two. You get a variety of data depending on the itmes you've selcted. You do have to expand both areas of the measure dialog box (something that should be expanded by default, IMO), but behond that I'm not seeing layers of complexity. Can you elaborate?

Doug Schaefer | Experienced Mechanical Design Engineer

Doug, the fact that you need to know to choose a CSYS to get simple X, Y, Z data is something you have to get use to. This is the primary use I have for the measure tool. Not two clicks (and having to hold the CTRL) but three. This is not obvious on 1st opening the measure tool.

I've been using Pro/E for 17 years and I believe you've always had to choose a CS to get X, Y, Z data.

Doug Schaefer | Experienced Mechanical Design Engineer

That explains why I never liked using the measure tool in any version of Pro|E



Brian gives a very good example of this where he lists the 9 steps needed to measure plane to surface or surface to surface.

I'm glad that you can use the tool without difficulty; perhaps it all will make sense in time. Part of it is what a person gets used to. I guess I'd still prefer doing the same operation in 4 steps. Inquiry/Surface to Surface/Select 2 surfaces.

I'm very green at this software yet I've seen it surpass the software I still use in some of it's capabilities. Still I hate how cumbersome it is.

21-Topaz II

Not to get too picky, but much of the difficulty Brian lists has to do with long standing issues with the selection method in Proe / Creo, not really the measure tool. I agree with him on that point, query select should give me the nearest item first, the next nearest second and so on. It doesn't adn if it did, that would make measuring much easier.

You can set your selection filter at the bottom right of the screen from 'All' to 'Surface' which would help.

I've used Proe / Creo since 1996, rev. 16. The measure tool in Creo is a significant improvement compared to what we had before.

Doug Schaefer | Experienced Mechanical Design Engineer

Those of you with maintenance, please vote on this idea:

5-Regular Member

I agree, it takes more mouse clicks than it used to.

Another thing that bugs me is, if you leave a measurement from a part on the screen then it shows up in any assmbly that part is in. And if you click on #Manage Analysis # Hide All in that assembly, it doesn't hide it. It has happened that I see a measurement in an assembly that I don't remember where I made it, and I have to go through opening the parts until I find the part that has the measurement, the hide it. Now that is annoying.

i have 2 mapkeys, one is "ss" and the other "id", im sure most can figure out ss is to measure surface to surface and id is to measure id's and od's.

if i use ss mapkey and get a measurement, it seems to work fine even though i dislike having to use the control button to select my second surface but nonetheless it seems to work ok and i close the measure tool, if i use the id mapkey that seems to work just fine also, my problem comes in when i run the ss mapkey to measure from surface to surface i get my value and then WITHOUT closing the original measure menu i hit id to measure an id, this will crash my session everytime but here is the kicker, i can run the id mapkey without a measure menu already open and then run the ss mapkey and it wont crash, but if i run the id mapkey after the ss mapkey, 100% gauranteed i will crash it.

this is the error i get when i crash the session when running measure mapkeys without closing the menu box between measures:

fatal error occured. a traceback has been written to XXXXXXXXXtraceback.log please send it to technical support.

i also really hate the fact that i CANNOT close the measure menu with a simple couple of middle mouse clicks.


Not using Creo yet - does ctrl-a still function as an all purpose reset?

Also - a plug to AutoIT, the all purpose tool that can eliminate window whack-a-mole with a routine for putting windows where you want them. I used it all the time to move the assembly component window to a second screen. So long pop-under; too small; always in the way; any number of other irritating conditions.

I'm curious if you've tried the new measure summary tool? I added it to the quick access toolbar so it's always available. I think it may be faster than your mapkeys.

Mapkey - 2 keystrokes, click, ctrl, click

Summary - click icon, click, ctrl, click.

The nice thing is you can use it for both measurements. If you click two surfaces, you get the distance between (and total surface area and angle, if they're planar). If you click the single diameter, you get the diameter measurement (and the surface area).

If you haven't played with the measurement summary tool, give it a try. It's a different workflow, but I find it much better than the old separate tools for each measurement type.

Doug Schaefer | Experienced Mechanical Design Engineer

you mean:

click icon, click, ctrl, click, expand, expand, resize window on the first measure of the session


click icon, click, ctrl, click, resize window on every measure after the first per session

i dont know man, i thought the measure tool worked just fine in WF.

i'm really trying to be open minded and as flexible as i can with creo, maybe i just havent got to the point where all the creo changes make sense in my head. its very frustrating for sure.

thanks for the reply Doug, i'll keep pushing forward with creo, i simply don't have any other option.


Top Tags