cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mechanism Design, Slot Connection Flipping

cmerani
Participant

Mechanism Design, Slot Connection Flipping

Hello All,

     I have what should be a relatively straight forward issue but I just cant seem to figure out what is happening. Working on Creo 3.0 M100.  I have a  top level assembly (FORKLIFT-PATH-ANIMATION) that contains one "part" and 3 sub assemblies.  The part (FLOW-THROUGH-LAYOUT) contains copy geom curves from a different parent assembly.  These curves are the established paths for the slot follower connections being discussed next.

     Now, each of the subassemblies (PATHFOLLOWER) are connected to the parent via slot follower connections.  The PATHFOLLOWER sub-assembly contains 2 items, a skeleton part and a shrinkwrapped model of a forklift.  The forklift model is fully assembled to the follower assembly using user defined constraints referencing the default assembly datums.  The skeleton part contains some datum points which are theorretical indicators of wheelbase/tire position.

Each PATHFOLLOWER is assembled with 3 constraints.  First is a Planar which establishes a connection of the top planes which places the vehicle with its tires on the ground.  The second two constraints are Slots.  The first slot uses the wheelbase point in the rear and the second slot uses the wheelbase point in the front of the skeleton.

     Two of the three subassemblies connect properly and face the correct direction.  They drag and animate properly.  The third subassembly will flip its direction so it faces backward when entering and exiting drag or animate.  If you attempt to edit the connection, it is easy to redefine and correct the direction/facing of the assembly.  However attempting to move the model again results in the connection flipping again.

I have attached a zip containing the backup files.  Also attached is a screenshot showing the issue

 

Thanks for the help guys

screenshot.JPG

2 REPLIES 2

Re: Mechanism Design, Slot Connection Flipping

I'm seeing the same behavior.  It would be interesting to see what tech support says.  Do you  have maintenance?

Re: Mechanism Design, Slot Connection Flipping

Hi Tom,

Thanks for the reply.  Unfortunately I do not have maintenance and in the past when I did, PTC was no help on these types of issues.  I did eventually get this assembly to connect properly and was able to run the animation but it took alot of fooling around and no particular "fix".

Announcements