cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Once again Creo 2.0 stopped working...

ptc-1812171
1-Newbie

Once again Creo 2.0 stopped working...

Whenever I start up I'm greeted with the fantastic message:

License request failed for feature

Requesting PROE_Foundation Adv ...

7788@hostid: (-15) Cannot connect to the license server system

I'm on my work's network. I'm able to access all local and remote connections. I've restarted several times (which eventually solved it last time this happend). My license is current. What the hell, PTC?

Also, Creo now takes several minutes to start up. This is getting ridiculous. WF4/5 wasn't nearly as bad as this. I feel like Creo 2.0 has been a massive step in the wrong direction.


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
6 REPLIES 6

Get on the horn with tech support and let them resolve the issue while they are on the phone.

I have a single license and single user application and I still got this problem. It is not the 1st time but when Dell upgraded my wireless driveres, it messed with CPU ID priorities. They plucked around in my registry and fixed it. I also had two different license servers running at the same time.

I was rebooting every time I had to start Creo 2. Now it is again behaving.

FlexLM uses the MAC adress of the network card which is in the registry under HKLM\Microsoft\WindowsNT\CurrentVersion\NetworkCards in first position. The sort order of the folders is alpha numeric, which means 10 comes before 2. Windows will load the driver only if the card is connected to a network.

You can change the order by renaming the folders.

If you use a portable network card the order may change. Look for a MediaSense patch in the registry to force Windows to load the driver even if the card is not connected to a network.

Reinhard

Reinhard, it was tech support that told me that the entry in the registry of "1" and "13" looked the same to either Windows or PTC. TS changed the "13" to "2" to solve the problem. "1" was my true physical network card and "13" was my WiFi card (disabled, BTW). Although the "1" took priority after the initial boot, it got lost pretty quick once you start using Windows apps. Sleep mode would inevitably cause a problem. And to top that, I use a cable to connect to the router. And when you use the CPUID.EXE, it finds the router, not the physical card in the computer.

All in all, it has become a pretty hokey system for locking licenses.

I believe this problem is caused by media sensing in Windows. It senses when various NIC cards are active or not and then turns off the inactive ones. This causes problems with Flexnet licensing. You need to turn off media sensing.

I suggest you download my talk from last year's PTC conference. You'll find it here:

http://portal.ptcuser.org/p/do/sd/sid=2464&type=0

The following is from that document.

Cheers - Dave Haigh.

(This is my first post to this site. You'll find me on the mail exploder. The only reason I replied to this is because someone linked to this in their question on that site. Not happy about it's coming demise.)

Media Sensing

===========

Add this registry setting:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\

Name: DisableDHCPMediaSense

Data type: REG_DWORD (Boolean)

Value: 1

What the PTC folks were doing was just changing the order in which flexnet sees the NIC cards. Without turning off media sensing this isn't going to help. It will just change the next time Windows senses a different card is inactive.

Here's how to change the NIC sort order

==============================

Expand the following key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkCards

This key will contain numbered folders corresponding to all of the network cards installed on the machine

Locate the desired folder by matching the "Description" field in the Registry Editor to the "Description" line from the ipconfig /all output for the desired network card

Rename this folder to number 1

Close the registry editor

Restart the machine

creo_lizenz.PNG

Can anybody help me?

This looks like an Academic Support issue - there's a separate forum for that.

Questions I would have are:

What version are the licenses for?

What version are you trying to run?

Have you been able to run this exact software on this exact machine (like in the last day or two) and now it doesn't or is this a new install that doesn't work?

Who is in charge of the license server?

I expect the academic licenses are handled a little differently than commercial ones, which is why I suggest contacting PTC academic for help.

Announcements