cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about the Community Ranking System, a fun gamification element of the PTC Community. X

Problem with using distributed batch - symbol corrupted / becoming box

AE_11094251
4-Participant

Problem with using distributed batch - symbol corrupted / becoming box

Hi everyone

I was trying to use distributed batch to export form .drw to .pdf.
I faced a problem that this symbol can't show up properly while using distributed batch feature

AE_11094251_0-1717401688059.png

How it looks in .drw

AE_11094251_1-1717401735601.png

When I export in manually, one by one

 

AE_11094251_3-1717401792574.png

When I try to use distributed batch.



Everything is ok except this one. Glad anyone can help me.
Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions


@AE_11094251 wrote:

Here are these 3 files. 
Does I need to modify something?


Hi,

INFO >>> files packed font.zip file are not modified.

 

I am sorry I do not have any idea how it is possible that you can see Mu character when you open prt0001.drw.1 drawing. It is possible that your Creo installation is modified in some unusual way.

 

Please place following note on the drawing. Do you see Mu character or square ?

MartinHanak_0-1717740616645.png

PROE_MAT is model parameter. Its value is defined by model relation PROE_MAT=MATERIAL_PARAM("condition").

condition value is located in material definition saved in model.

MartinHanak_1-1717740789668.png

 


Martin Hanák

View solution in original post

11 REPLIES 11

Hi,

1.] please upload test drawing (packed in zip file)

2.] what font do you use to display greek mu character ?

3.] what Creo version do you use ?

4.] what ttd file do you use do export PDF ?


Martin Hanák

Here is it, I attach .drw .prt .frm and .ttd as an example.
I use Creo7 version.
I don't know about the font. It was set a long time ago by senior worker. May you check it, refer in the file?

Thank you


@AE_11094251 wrote:

Here is it, I attach .drw .prt .frm and .ttd as an example.
I use Creo7 version.
I don't know about the font. It was set a long time ago by senior worker. May you check it, refer in the file?

Thank you


Hi,

I opened your prt0001.drw and I can see your "picture no.3".

  • when I display text properties of problematic cell I can see that text is displayed using font named font
  • font named font does not contain definition of Mu letter ... therefore the square is displayed
  • when I set different font I can see Mu letter ... replay uploaded font_assignment.mp4 video

 


Martin Hanák

Is it because your PC doesn't have font? so, it doesn't reveal in creo? 

But why the Mu looks normal in my creo?

Are there any things that I can do? can I change the font for Mu symbol only? not for entire cell, I want 3-5 text still on previous font.


@AE_11094251 wrote:

Is it because your PC doesn't have font? so, it doesn't reveal in creo? 

But why the Mu looks normal in my creo?

Are there any things that I can do? can I change the font for Mu symbol only? not for entire cell, I want 3-5 text still on previous font.


Hi,

INFO ...every Creo installation contains font named font. Unfortunatelly font definition does not contain Mu letter.

Please open Properties dialog box as shown in my video and publish picture of the window. I need to see what font is set in Font field.

MartinHanak_0-1717652373275.png

 


Martin Hanák

Aaa, I see.
Here is mine.

AE_11094251_0-1717659074907.png

 


@AE_11094251 wrote:

Aaa, I see.
Here is mine.

AE_11094251_0-1717659074907.png

 


Hi,

it looks like your Creo installation uses modified font named font-AND- Distributed batch probably uses different Creo installation with OOTB font named font.

 

Please read carefully following information related to font named font -AND- my Creo installation

  • below mentioned information is related to Creo installation installed with English language, only
  • by default the "starting point" to this font is E:\PTC\Creo7_050\Creo 7.0.5.0\Common Files\text\usascii\font.ndx file
  • font.ndx file contains 3 lines
ascii.fnt
special.fnt
latin_1.fnt
  • these files are located in E:\PTC\Creo7_050\Creo 7.0.5.0\Common Files\x86e_win64\text\usascii
    • please pack these files into  zip files and upload this zip file

 

 


Martin Hanák

Here are these 3 files. 
Does I need to modify something?


@AE_11094251 wrote:

Here are these 3 files. 
Does I need to modify something?


Hi,

INFO >>> files packed font.zip file are not modified.

 

I am sorry I do not have any idea how it is possible that you can see Mu character when you open prt0001.drw.1 drawing. It is possible that your Creo installation is modified in some unusual way.

 

Please place following note on the drawing. Do you see Mu character or square ?

MartinHanak_0-1717740616645.png

PROE_MAT is model parameter. Its value is defined by model relation PROE_MAT=MATERIAL_PARAM("condition").

condition value is located in material definition saved in model.

MartinHanak_1-1717740789668.png

 


Martin Hanák

Hi,

just one additional note ... maybe the secret of the problem is related to your personal config.pro file. This file is loaded when you work with Creo interactively -AND- is not loaded when you generate PDF using Distributed batch.


Martin Hanák

Hello @AE_11094251,

  

It looks like you have some responses from some community members. If any of these replies helped you solve your question please mark the appropriate reply as the Accepted Solution. 

Of course, if you have more to share on your issue, please let the Community know so other community members can continue to help you.

Thanks,
Community Moderation Team.

Top Tags